[App_rpt] Remote setup help please.

Steve Rodgers hwstar at rodgers.sdcoxmail.com
Fri Oct 13 00:53:30 EDT 2006


Gary,

Here's a half-duplex remote base checklist taken from a prior  [app_rpt] mail 
list thread:


1. The ARIB card needs to have the 4W/2W switch set to 2W (2 wire).

2. Only one cable should be connected from the channelbank to the ARIB card. 
This should go from the FXS port  to J1 on the ARIB card.

3. There should not be a txchannel defined in the nodes section of rpt.conf.

4. Since you are running as a remote base, you must add a 'y' argument to the 
end of the node definition, like this: 101 = radio at me.asterisk.net/101,y

5. /etc/asterisk/zapata.conf should have em_txrx for signalling on Zap/x.

6. /etc/zaptel.conf should have channel type for Zap/x set to e&m

Sample remote configuration for rpt.conf (taken from my setup):

[101]

rxchannel = Zap/x                     ; Rx audio/signalling channel
remote = ft897
functions = remote-functions
phone_functions = remote-functions

;
; Remote base function table
;

[remote-functions]
1=remote,2                              ; Set freq.
2=remote,3                              ; Set tx PL tone
3=remote,4                              ; Set rx PL tone
40=remote,100                           ; Rx PL off
41=remote,101                           ; Rx PL on
42=remote,102                           ; Tx PL off
43=remote,103                           ; Tx PL on
44=remote,104                           ; Low Power
45=remote,105                           ; Medium Power
46=remote,106                           ; High Power
711=remote,107                          ; Bump -20
714=remote,108                          ; Bump -100
717=remote,109                          ; Bump -500
713=remote,110                          ; Bump +20
716=remote,111                          ; Bump +100
719=remote,112                          ; Bump +500
721=remote,113                          ; Scan - slow
724=remote,114                          ; Scan - quick
727=remote,115                          ; Scan - fast
723=remote,116                          ; Scan + slow
726=remote,117                          ; Scan + quick
729=remote,118                          ; Scan + fast
79=remote,119                           ; Tune
51=remote,5                             ; Long status query
52=remote,140                           ; Short status query
6=remote,6                              ; Set mode
8=remote,99                            ; User login
9=cop,6                                   ; Phone ptt

[nodes]

101 = radio at me.asterisk.net/101,y


Steve


On Thursday 12 October 2006 21:23, Gary Young wrote:
> Can some one tell me what the proper config entries are to get a dumb
> remote working?
>
> Should this work? On my system I only can get RX to work from the remote,
> but no TX out the remote.
>
>
> [1001]
> rxchannel = Zap/1
> functions = functions-remote
> remote = y
>
> [functions-remote]
>
> 0=cop,6						; Phone PTT
>
> [nodes]
>
> 1001 = radio at remote.remote-address.com/1001,y
>
>
>
>
>
> Thanks, Gary
>
>
> _______________________________________________
> App_rpt mailing list
> App_rpt at lists.illiana.net
> http://lists.illiana.net/mailman/listinfo/app_rpt



More information about the App_rpt-users mailing list