[App_rpt] issue with hid interface in chan_usbradio

K3XH k3xh at embarqmail.com
Mon Oct 22 22:45:47 EDT 2007


Steve / Jim Duuuude! ...


Thanks for the reply...  Yeah, I've been running Asterisk under it's own
userid/group on my other box, so I tried setting up the rpt box the same.

But what I've finally found is...  that the Linux kernel claims hid 
interfaces when devices are 'inserted' and then does not seem to readily 
relinquish them to 'user-space' applications (???).

There 'supposedly' is a means to indicate to the kernel to 'ignore' a
particular class of device by rebuilding the kernel with a modified
hid_blacklist struct (in source file
'/usr/src/kernels/linux-2.6.23.1/drivers/hid/usbhid/hid-quirks.c' for
kernel 2.6.23.1) with the hex code of the vendor and deviceid to ignore.
  I tried building the kernel in this fashion, but the issue remains...
   Go figure...  So I decided to make my life easier and just run 
Asterisk as root.  At least I now have the latest kernel running on my 
box...

Thanks... mike.
...app_rpt rocks....


Jim Duuuude wrote:
> well, to my knowledge you have to run asterisk as root. I never tested it 
> any other way, and
> I dont know of any other way of doing it.




More information about the App_rpt-users mailing list