[App_rpt] No RX signal detected

John Yaldwyn jy at 4hf.net
Sat Oct 4 04:18:52 EDT 2008


Hold fire that man!

I've just done what I should have done first and that is to read back thru most of the reflector archive.

Taking on board a tip about commenting out the CTCSS statement in the zaptel.conf file when not using CTCSS, I commented out the rxctcss statement in the usbradio.conf and voilĂ  problem solved, everything is working.

Could comment out the txctcss statement if I'm not using CTCSS on transmit to save CPU power?

I'm now curious about the [general] context statements:

rxcpusaver=0
txcpusaver=0

What do these do?

Regards, John ZL4JY



-----Original Message-----
From: app_rpt-bounces at lists.illiana.net [mailto:app_rpt-bounces at lists.illiana.net] On Behalf Of John Yaldwyn
Sent: Saturday, 4 October 2008 18:03
To: app_rpt at lists.illiana.net
Subject: [App_rpt] No RX signal detected

Hi All,

This will no doubt be one of those blindly obvious problems but ....

I'm reasonably familiar with Asterisk in normal IAX/Sip type environments.  I've just built my own repeater system basically using ACID to get an idea of the technology.  I've removed the Allstar registrations and reg script as it is a single node stand alone system at the moment.

A lot works.  Morse ID, announcements, and audio (from dialing in on the phone patch) are all transmitted.  However try as I might I can't get audio from the receiver input to be passed to the transmitter or to a phone extension and the TX is never keyed from the receiver.

The usbradio.conf file is set as I understand for carrier squelch:

carrierfrom=usb
ctcssfrom=no

The radio tune procedure worked pretty much OK (except Asterisk crashed when I ran the radio tune txtone 0 command but all other radio tune commands are fine).  DTMF digits are also all received and decoded OK as reported by debug output but no audio to the phone line when the auto patch is up.  When the patch is up the TX keys fine.

The squelch from the radio is recognized by the USB interface as I get radiochan_usbradio NOTICES showing that rxcarrierdetect is following the radio mute OK. But Rpt stats indicates signal on input = no and doesn't change.

The rpt.conf file is the example other than the node number and I've also tried adding duplex=4 to the node context but this doesn't change things.

A possibly related question is the purpose of the [radio-secure] context in extensions.conf.  What is its purpose and where is it referenced from? I already have a context for incoming telephone calls to the system ie 1234,1,Rpt,1234|D 

Suggestions appreciated!

Regards, John ZL4JY
 
_______________________________________________
App_rpt mailing list
App_rpt at lists.illiana.net
http://lists.illiana.net/mailman/listinfo/app_rpt



More information about the App_rpt-users mailing list