[App_rpt] Dial-in access to remote base

hwstar at rodgers.sdcoxmail.com hwstar at rodgers.sdcoxmail.com
Thu Oct 9 14:41:11 EDT 2008


See below

Steve
WA6ZFT

> 
> From: David McGough <kb4fxc at inttek.net>
> Date: 2008/10/09 Thu AM 10:56:12 PDT
> To: Asterisk Repeater Controler <app_rpt at lists.illiana.net>
> Subject: Re: [App_rpt] Dial-in access to remote base
> 
> 
> 
> Hi Steve,
> 
> Thanks for the help! I'm just about there now, I think! I added the config
> statements you suggested and now I can key the remote base via '*9' and
> unkey via '#'.....But this seems a bit flakey--I can get the remote base
> keyed, but, it doesn't always unkey..Also, VOX mode still doesn't want to
> work.
> 
> Some other observations are: I noticed that if I use simple mode, once the
> remote base is keyed it won't unkey....Not really an issue to me, but, an
> observation.  And, function *7 (link status) causes a seg fault--should 
> that happen?

First off: Link status doesn't make sense on a remote base!
Remote bases are for exclusive use by one user at a time! 

Key-unkey flakiness. Two things to check:

1. What happens when you configure the HF and VHF radios as a standard node (with duplex=0)? The remote base code is separate from the standard node code, and there could be a keying bug could be in the remote base code. 

2. Please confirm the phone key/unkey is not flakey on your standard node.This key/unkey issue could be a SIP configuration issue.


> 
> Please note as I mentioned earlier that VOX, etc., works fine on the
> repeater node (#21), interestingly....
> 
> Here are my current configs:
> 
> rpt.conf
> --------
> 
> [22]                            ; Change this to your assigned node number
> rxchannel = Radio/usb1                  ; Rx audio/signalling channel
> duplex=0
> remote=y
> functions = functions_remote
> phone_functions = functions_remote
> authlevel = 0                           ; should be set to 0 or left undefined.
> remote_inact_timeout = 0
> remote_timeout = 0
> remote_timeout_warning = 0
> remote_timeout_warning_freq = 0
> voxtimeout=5000                         ; time to let vox talk in ms
> voxrecover=500                          ; time to take from vox one timed out in ms
> simplexpatchdelay=10                    ; # of 20 ms frames to delay audio
> simplexphonedelay=10                    ; # of 20 ms frames to delay audio
> 
> [functions_remote]
> 7=ilink,5                               ; Link status
> 8=status,2                              ; Time
> 9=cop,6   	                      ; Phone TX key
> 
> 
> extensions.conf
> ----------------
> 
> [radio-control]
> exten=22,1,Answer
> exten=22,n,Playback,rpt/node
> exten=22,n,Playback,digits/2
> exten=22,n,Playback,digits/2
> exten=22,n,Rpt,22|Pv
> 
> 
> 
> 
> On Thu, 9 Oct 2008 hwstar at rodgers.sdcoxmail.com wrote:
> 
> > 
> > 
> > Do  you have a functions_remote stanza and is phone_functions pointing 
> to a  remote_functions function table? Do you have a 98=cop,6 statement in 
> the remote_functions stanza?
> > 
> > [functions_remote]
> > .
> > .
> > .
> > 98=cop,6
> > 
> > Finally,  is authlevel set to 0 or undefined in the node stanza? If 
> authlevel  is >0, you won't be able to key anything and 20 seconds later, 
> you'll be disconnected! 
> >  
> > 
> > [XXXX]
> > 
> > rxchannel = Zap/2       
> > remote = ft897
> > functions = remote-functions
> > phone_functions = remote-functions ; important!
> > authlevel = 0; should be set to 0 or left undefined.
> > 
> > 
> > Steve
> > WA6ZFT
> > 
> > 
> > > 
> > > From: David McGough <kb4fxc at inttek.net>
> > > Date: 2008/10/09 Thu AM 07:53:24 PDT
> > > To: app_rpt at lists.illiana.net
> > > Subject: [App_rpt] Dial-in access to remote base
> > > 
> > > 
> > > Hi Everyone,
> > > 
> > > I'm having a problem using my remote base via dial-in access to asterisk
> > > and I'm trying to figure out how to fix it....
> > > 
> > > On my asterisk box, I'm controlling 3 nodes currently. The first (node
> > > #21) is a UHF repeater, and the second (node #22) and third (node #23)  
> > > nodes are simplex VHF and HF remote base radios....All these nodes are 
> > > working fine, etc.
> > > 
> > > The dial-in and autopatch functions work great with my repeater node
> > > (#21) ....But, for the remote base nodes, I can't key the rig from the SIP
> > > phone no matter what I try! I've tried all the phone modes: dumb, 
> > > normal, simple and VOX mode from the extensions.conf.  Nothing works.
> > > 
> > > Here is a snippet of my extensions.conf:
> > > 
> > > [radio-control]
> > > exten=21,1,Answer		; Works great!
> > > exten=21,n,Playback,rpt/node
> > > exten=21,n,Playback,digits/2
> > > exten=21,n,Playback,digits/1
> > > exten=21,n,Rpt,21|Pv
> > >                                                                                                                                                             
> > > exten=22,1,Answer		; Can't key the remote base
> > > exten=22,n,Playback,rpt/node
> > > exten=22,n,Playback,digits/2
> > > exten=22,n,Playback,digits/2
> > > exten=22,n,Rpt,22|Pv
> > > 
> > > 
> > > snippet of rpt.conf:
> > > 
> > > [22]
> > > rxchannel = Radio/usb1                  ; Rx audio/signalling channel
> > > duplex=0
> > > remote=y
> > > remote_inact_timeout = 0
> > > remote_timeout = 0
> > > remote_timeout_warning = 0
> > > remote_timeout_warning_freq = 0
> > > voxtimeout=5000                         ; time to let vox talk in ms
> > > voxrecover=500                          ; time to take from vox one timed out in ms
> > > simplexpatchdelay=5                     ; # of 20 ms frames to delay audio
> > > simplexphonedelay=5                     ; # of 20 ms frames to delay audio
> > > 
> > > [nodes]
> > > 21 = radio at 127.0.0.1/21,NONE
> > > 22 = radio at 127.0.0.1/22,NONE,y
> > > 23 = radio at 127.0.0.1/23,NONE,y
> > > 
> > > 
> > > 
> > > Thanks in advance!
> > > 
> > > 73, David KB4FXC
> > > 
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > App_rpt mailing list
> > > App_rpt at lists.illiana.net
> > > http://lists.illiana.net/mailman/listinfo/app_rpt
> > > 
> > 
> > _______________________________________________
> > App_rpt mailing list
> > App_rpt at lists.illiana.net
> > http://lists.illiana.net/mailman/listinfo/app_rpt
> > 
> 
> _______________________________________________
> App_rpt mailing list
> App_rpt at lists.illiana.net
> http://lists.illiana.net/mailman/listinfo/app_rpt
> 




More information about the App_rpt-users mailing list