[App_rpt] Problems with Echolink on app_rpt

Stephen Rodgers hwstar at rodgers.sdcoxmail.com
Sat Oct 11 21:12:27 EDT 2008


By removing the radio-secure context you have now broken your incoming
allstarlink connectivity. The problem is the fact that there is a dollar
sign and curly braces around the node number 2250!! Restore the old
radio-secure context and get rid of the dollar sign and curly braces,
then change the context back to radio-secure in echolink.conf and
everything should be ok.

Steve
WA6ZFT



Jim Duuuude wrote:
> If thats the case, then youre not running the latest version of app_rpt. That will not happen in the latest versions.
> 
> Date: Sat, 11 Oct 2008 16:06:17 +0100
> From: g4rky at yahoo.co.uk
> To: app_rpt at lists.illiana.net
> Subject: Re: [App_rpt] Problems with Echolink on app_rpt
> 
> Hi Steve and thanks for the reply.
>  
> After much messing about - and learning in the porcess of course - I've fixed it!
>  
> The context [radio-secure] in the example given in the instructions at http://app-rpt.qrvc.com/echolink.html where it tells you what to put in your extensions.conf file may be incorrect.
> 
>  
> I had the following in there and it didnt work for incoming calls:
>  
> [radio-secure]
> exten => ${2250},1,rpt,${2250}
> I replaced it with:
>  
> [echolink-in]
> exten => 2250,1,rpt(2250|X)
> and commented out the reference to [radio-secure] in my Echolink.conf file and added one at the end for [echolink-in] and everything is now working, both in and out!
>  
> Clearly I can see the differebetween the two statements but being a real Asterisk newbie, it really means nothing to me so I dont know what the effect of the wrong statement would be!
>  
> Sorry to be so vague but I have now got it all working, so thank you for replying.
>  
> Now, who can tell me how to get IRLP working?  Please?
>  
> Thanks everyone and have a great weekend
>  
> Kind regards,
>  
> Matt
> G4RKY
> Node 2250 & 2237
> 
> 
> 2008/10/11 <hwstar at rodgers.sdcoxmail.com>
> 
> Matt,
> 
> If you followed the instructions is the ACID sysadmin manual, everything should be fine. Since database show
> 
> is working, most of it is up and running. You might want to post your echolink.conf file with rhe password obiliterated
> to the list so that we can see if it is ok.
> 
> If you try to connect before everyone gets an updated list
> 
> the connection will fail. Please try after about an hour
> so that everyone gets a list with your node in it.
> 
> Something else to check: Is your node showing up on echolink.org?
> 
> 
> Finally, don't worry about this message:
> 
> 
>> WARNING[5786] file.c:1198 waitstream_core: Unexpected control subclass '13'
> 
> Steve
> WA6ZFT
> 
> 
> 
> 
>> From: "Matt Beasant" <g4rky at yahoo.co.uk>
> 
>> Date: 2008/10/11 Sat AM 01:55:47 PDT
>> To: "Asterisk Repeater Controler" <app_rpt at lists.illiana.net>
>> Subject: [App_rpt] Problems with Echolink on app_rpt
> 
> 
> 
> 
>> Dear all,
>>
>> I've upgraded my node to the latest release and have attempted to get
>> Echolink working on my node.
>>
>> However, I'm having problems and wondered if anyone could point me in the
> 
>> right direction for a fix?
>>
>> When I try to make an outgoing call from my node to an echolink node, I
>> instantly get the "node connection failed" message.
>>
>> On the CLI, the announcement text is immediately preceeded by:
> 
>> WARNING[5786] file.c:1198 waitstream_core: Unexpected control subclass '13'
>>
>> When I try to make a call IN to my node form an Echolink node, I see:
>>
>> ERROR[2508]: chan_echolink.c:2165 do_new_call: Cannot find DB entry for
> 
>> a/ipaddr/81.156.xxx.xxx
>>
>> However, I do frequently see messages such as:
>>
>> NOTICE[2507]: chan_echolink.c:1758 sendcmd: Received OK from Echolink server
>> europe.echolink.org
> 
>> and the database show command works fine also.
>>
>> Do I need to follow these instructions here :
>> http://app-rpt.qrvc.com/echolink.html  or is my node already up to date
> 
>> enough to not have to do this?
>>
>> I also noted the existence of an IRLP config file in the config examples - I
>> need IRLP functionality on my node and so is this something I can use too?
>>
> 
>> Thanks in advance for any and all help received!
>>
>> Kind regards,
>>
>> Matt
>> G4RKY
>> node 2250 & 2237
>>
>>
> 
> _______________________________________________
> 
> App_rpt mailing list
> App_rpt at lists.illiana.net
> http://lists.illiana.net/mailman/listinfo/app_rpt
> 
> 
> 
> _______________________________________________
> App_rpt mailing list
> App_rpt at lists.illiana.net
> http://lists.illiana.net/mailman/listinfo/app_rpt
> 
> 
> 
> 
> 
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> App_rpt mailing list
> App_rpt at lists.illiana.net
> http://lists.illiana.net/mailman/listinfo/app_rpt




More information about the App_rpt-users mailing list