[App_rpt-users] First experience with ACID app_rpt & usbradio audio popping problem.

Steve Gladden steve at michiganbroadband.com
Wed Nov 11 18:58:15 EST 2009


Short version:

*Installed ACID
*Have audio popping problem with USB transmit (output) audio.
*I'm not surprised didn't expect it to work perfectly first attempt.
*Only tried one combinarion of hardware/cpu/motherboard so far.. I need 
to try other motherboards/CPUs.
* Tried 3 different USB devices and ports.
* played with moving interrupts disabling motehrboard built-on hardware etc.
* CPU runs at about 10% while USB radio is active..
* Loading PC heavily by running gzip -9 seti at home Lots of disk access 
lots of network activity seem to have zero impact on the popping 
frequentness.

* I'd like to know if anyone else here has had this or similar problems 
with consistent audio from the USB device (CM-108) and what they may 
have done
  to make it work better.




Long Version:

I gave it a go and went the 'easy' route just to get started..
I ended up trying it out on that 1.1Ghz AMD Duron CPU rack mount server..
I must say I'm extremely excited & please with this software..
But it would be too good to be true if it all just worked first try.. 
and of course would take all the 'fun'
out of getting it to work..
Ok enough small talk (haha)
Here's what I have going on:

Everything works except I am getting intermittent audio popping in the 
audio output of the USB sound device.
VERY intermittent maybe about 3-4 'pops' every minute on average.. 10 at 
most sometimes.. and other times several minutes go by without a 'pop'.
It seems to mostly occur during the CW ID beacon which I have going 
every minute..
The pops that are heard only happen when the 'transmitter' is active 
sending PL or CW ID or PLAYBACK...
My test arrangement has "radio key" running to produce continuous PL and 
occasional audio popping.
There is no radio actually hooked up yet.

OK will talk about the hardware a bit.. and probably worse case scenario 
here due to an 'all in one' motherboard..
It's a MSI 6378 'budget' Athlon board.. everything built on.
Has USB 1.1  *NOT 2*
I don't know/think this matters for a sound device.

Here's all of the things I have tried all of which have absolutely no 
effect on the intermittent popping...

1. Disabling everything not needed on motherboard including ethernet for 
test..
    ethernet + usb share an interrup line and there is no ability to 
re-route this in the bios
    so I turned off the ethernet on the motherboard for testing.

2. Carefully monitor CPU during audio pops running 'top' around 20 
updates per second (this alone takes more CPU load than asterisk 
/app_rpt + usb radio.


3. On this motherboard the USB controller and ethernet share a PCI 
interuupt line and you cannot change it.
    I've tried disabling the built on ethernet and still get the popping..
    I've also flood and large pinged the machine which genreates huge 
numbers of interrups from the ethernet chip and this has no effect on 
the popping..

4. Tried other USB fobs with same chipset.
    Created various types of heavy system activity to see if it has any 
impact on the popping heavy disk use hevy network use and heavy vga use 
(text mode)
    moving interrupts  (changing them) on the motherboard.. getting usb 
controller onto a different interuupt (ethernet ends up on same).

5. Measured and scoped 5V output on USB to be sure 'popping' sound is 
not coming from 5V power supply.

6. Am really looking to hear what some others experience has been with 
this..
    what works and what does not?
    The popping very much sounds like an interrupt issue or some kind of 
issue where the task of sending and audio stream is completely dropped 
for something else
and then resumed leaving lots of holes heard as pops in the output stream.





















































-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.




More information about the App_rpt-users mailing list