[App_rpt-users] First experience with ACID app_rpt & usbradio audio popping problem.

Steve Gladden steve at michiganbroadband.com
Sun Nov 15 02:19:20 EST 2009


Here's a youtube video of the popping I describe from the USB device:

http://www.youtube.com/watch?v=lqYwhtuVLDs

If you have the patience to actually listen to about 3 minutes of 100Hz 
PL and the once per minute CWIDs you'll hear the audio
dropouts I am talking about..
Also a look on the scope (you'll also see it in that video) the audio is 
actually completely dropping off like cpu is elsewhere and the stream is 
not being processed for
short bursts of time but very randomly and sometimes not for over a 
minute at a time!
This sorta indicates to me it's not a CPU issue as CPU is maxed at only 
30% during testing and machine is still very responsive with seemingly 
plenty of CPU overhead to spare..

I'm continuing to try this out.
My testing approach is to try it out on some older/lower end systems 
first and then work my way up..
I'd like to know what types of older not as fast systems will run the 
simplest node yet still be able to support
usbradio.
So far I'm at still at the very low end of systems and have not seen one 
work solidly yet..
I'm testing on system #3 now..
This one is an Intel Pentium3 system with a 600MHz CPU.

I'm still getting the audio 'popping' as before different & less 
frequent than on the AMD 1.1GHz system..
This system actually has the USB on a dedicated interrupt this time.

Using top During TX/RX the CPU is at a steady 30% Utilization where on 
the Duron 1.1Ghz box it was around 10%

Pop's on this system average 3-4 per minute.

My test is as follows... no radio hooked up and monitoring TX audio from 
USB audio device.

have CWID set to ever 60 seconds

issue a manual "radio key"

This sends continuous PL 100Hz out the audio device + CWID every minute.

I notice the audio dropouts very intermittently but a bit more common 
around the cwid event.





















Steve Gladden wrote:
> Hi David.. it's not a terribly loud popping it's right with the normal audio
> levels
> It really sounds like 'holes' in the processing small abrupt dropouts of the
> stream..
> Very random in timing maybe 5-15 hits per minute when I key the radio with
> PL..
>
> Seems to more frequently happen on/around the CWID but still is happening
> very randomly.
>
> CPU utilization is ~10% while radio keyed producing PL and CWID..
> Have radio continuously keyed (no actual radio) and CDID beacon going every
> minute.
>
> 5-15 'dropouts' per minute.
>
> I've tried to isolate it by throwing different tasks at the hardware/CPU to
> see if the audio dropouts
> Would increase or not during heavy CPU utilization or maxing out IO on
> network hard drives etc.
>
> Checked alsa mixer to make sure there were no open turned way up audio
> inputs or mic monitor turned on..
> Turned down all input levels and this had no effect on the dropouts either.
>
> One thing I have not tried (but will not matter) is to hook a usb HDD to the
> usb port and give the usb controller
> Itself some activity besides the usbradio port and see if this impacts the
> issue.
>
> This might tend to point me back to the usb controller itself having an
> issue..
>
> I should also try a PCI external USB card on the motherboard and give it
> it's own interrupt.
>
> :-)
>
>
>
>
>
>
>
>
>
> -----Original Message-----
> From: David McGough [mailto:kb4fxc at inttek.net] 
> Sent: Thursday, November 12, 2009 6:57 PM
> To: Steve Gladden
> Cc: app_rpt-users at qrvc.com
> Subject: Re: [App_rpt-users] First experience with ACID app_rpt & usbradio
> audio popping problem.
>
>
> Hi Steve,
>
> What exactly do you mean by "popping"?? Is it a loud POP! like a drum or 
> is it a momentary audio drop-out or choppiness??
>
> The reason I ask about choppiness is that I've experienced this issue. 
> But, I've never had loud POPS! ....
>
> 73, David kb4fxc
>
>
>
> On Wed, 11 Nov 2009, Steve Gladden wrote:
>
>   
>> Short version:
>>
>> *Installed ACID
>> *Have audio popping problem with USB transmit (output) audio.
>> *I'm not surprised didn't expect it to work perfectly first attempt.
>> *Only tried one combinarion of hardware/cpu/motherboard so far.. I need 
>> to try other motherboards/CPUs.
>> * Tried 3 different USB devices and ports.
>> * played with moving interrupts disabling motehrboard built-on hardware
>>     
> etc.
>   
>> * CPU runs at about 10% while USB radio is active..
>> * Loading PC heavily by running gzip -9 seti at home Lots of disk access 
>> lots of network activity seem to have zero impact on the popping 
>> frequentness.
>>
>> * I'd like to know if anyone else here has had this or similar problems 
>> with consistent audio from the USB device (CM-108) and what they may 
>> have done
>>   to make it work better.
>>
>>
>>
>>
>> Long Version:
>>
>> I gave it a go and went the 'easy' route just to get started..
>> I ended up trying it out on that 1.1Ghz AMD Duron CPU rack mount server..
>> I must say I'm extremely excited & please with this software..
>> But it would be too good to be true if it all just worked first try.. 
>> and of course would take all the 'fun'
>> out of getting it to work..
>> Ok enough small talk (haha)
>> Here's what I have going on:
>>
>> Everything works except I am getting intermittent audio popping in the 
>> audio output of the USB sound device.
>> VERY intermittent maybe about 3-4 'pops' every minute on average.. 10 at 
>> most sometimes.. and other times several minutes go by without a 'pop'.
>> It seems to mostly occur during the CW ID beacon which I have going 
>> every minute..
>> The pops that are heard only happen when the 'transmitter' is active 
>> sending PL or CW ID or PLAYBACK...
>> My test arrangement has "radio key" running to produce continuous PL and 
>> occasional audio popping.
>> There is no radio actually hooked up yet.
>>
>> OK will talk about the hardware a bit.. and probably worse case scenario 
>> here due to an 'all in one' motherboard..
>> It's a MSI 6378 'budget' Athlon board.. everything built on.
>> Has USB 1.1  *NOT 2*
>> I don't know/think this matters for a sound device.
>>
>> Here's all of the things I have tried all of which have absolutely no 
>> effect on the intermittent popping...
>>
>> 1. Disabling everything not needed on motherboard including ethernet for 
>> test..
>>     ethernet + usb share an interrup line and there is no ability to 
>> re-route this in the bios
>>     so I turned off the ethernet on the motherboard for testing.
>>
>> 2. Carefully monitor CPU during audio pops running 'top' around 20 
>> updates per second (this alone takes more CPU load than asterisk 
>> /app_rpt + usb radio.
>>
>>
>> 3. On this motherboard the USB controller and ethernet share a PCI 
>> interuupt line and you cannot change it.
>>     I've tried disabling the built on ethernet and still get the popping..
>>     I've also flood and large pinged the machine which genreates huge 
>> numbers of interrups from the ethernet chip and this has no effect on 
>> the popping..
>>
>> 4. Tried other USB fobs with same chipset.
>>     Created various types of heavy system activity to see if it has any 
>> impact on the popping heavy disk use hevy network use and heavy vga use 
>> (text mode)
>>     moving interrupts  (changing them) on the motherboard.. getting usb 
>> controller onto a different interuupt (ethernet ends up on same).
>>
>> 5. Measured and scoped 5V output on USB to be sure 'popping' sound is 
>> not coming from 5V power supply.
>>
>> 6. Am really looking to hear what some others experience has been with 
>> this..
>>     what works and what does not?
>>     The popping very much sounds like an interrupt issue or some kind of 
>> issue where the task of sending and audio stream is completely dropped 
>> for something else
>> and then resumed leaving lots of holes heard as pops in the output stream.
>>
>>
>>     
>
>
>   


-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.




More information about the App_rpt-users mailing list