[App_rpt-users] First experience with ACID app_rpt & usbradio audio popping problem.

Steve Gladden steve at michiganbroadband.com
Tue Nov 17 14:27:01 EST 2009


Stephen Rodgers wrote:
> Steve Gladden wrote:
>   
>> Hi David.. it's not a terribly loud popping it's right with the normal audio
>> levels
>> It really sounds like 'holes' in the processing small abrupt dropouts of the
>> stream..
>> Very random in timing maybe 5-15 hits per minute when I key the radio with
>> PL..
>>
>> Seems to more frequently happen on/around the CWID but still is happening
>> very randomly.
>>
>> CPU utilization is ~10% while radio keyed producing PL and CWID..
>> Have radio continuously keyed (no actual radio) and CDID beacon going every
>> minute.
>>
>> 5-15 'dropouts' per minute.
>>
>> I've tried to isolate it by throwing different tasks at the hardware/CPU to
>> see if the audio dropouts
>> Would increase or not during heavy CPU utilization or maxing out IO on
>> network hard drives etc.
>>
>> Checked alsa mixer to make sure there were no open turned way up audio
>> inputs or mic monitor turned on..
>> Turned down all input levels and this had no effect on the dropouts either.
>>
>> One thing I have not tried (but will not matter) is to hook a usb HDD to the
>> usb port and give the usb controller
>> Itself some activity besides the usbradio port and see if this impacts the
>> issue.
>>
>> This might tend to point me back to the usb controller itself having an
>> issue..
>>
>> I should also try a PCI external USB card on the motherboard and give it
>> it's own interrupt.
>>
>> :-)
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> -----Original Message-----
>> From: David McGough [mailto:kb4fxc at inttek.net] 
>> Sent: Thursday, November 12, 2009 6:57 PM
>> To: Steve Gladden
>> Cc: app_rpt-users at qrvc.com
>> Subject: Re: [App_rpt-users] First experience with ACID app_rpt & usbradio
>> audio popping problem.
>>
>>
>> Hi Steve,
>>
>> What exactly do you mean by "popping"?? Is it a loud POP! like a drum or 
>> is it a momentary audio drop-out or choppiness??
>>
>> The reason I ask about choppiness is that I've experienced this issue. 
>> But, I've never had loud POPS! ....
>>
>> 73, David kb4fxc
>>
>>
>>
>> On Wed, 11 Nov 2009, Steve Gladden wrote:
>>
>>     
>>> Short version:
>>>
>>> *Installed ACID
>>> *Have audio popping problem with USB transmit (output) audio.
>>> *I'm not surprised didn't expect it to work perfectly first attempt.
>>> *Only tried one combinarion of hardware/cpu/motherboard so far.. I need 
>>> to try other motherboards/CPUs.
>>> * Tried 3 different USB devices and ports.
>>> * played with moving interrupts disabling motehrboard built-on hardware
>>>       
>> etc.
>>     
>>> * CPU runs at about 10% while USB radio is active..
>>> * Loading PC heavily by running gzip -9 seti at home Lots of disk access 
>>> lots of network activity seem to have zero impact on the popping 
>>> frequentness.
>>>
>>> * I'd like to know if anyone else here has had this or similar problems 
>>> with consistent audio from the USB device (CM-108) and what they may 
>>> have done
>>>   to make it work better.
>>>
>>>
>>>
>>>
>>> Long Version:
>>>
>>> I gave it a go and went the 'easy' route just to get started..
>>> I ended up trying it out on that 1.1Ghz AMD Duron CPU rack mount server..
>>> I must say I'm extremely excited & please with this software..
>>> But it would be too good to be true if it all just worked first try.. 
>>> and of course would take all the 'fun'
>>> out of getting it to work..
>>> Ok enough small talk (haha)
>>> Here's what I have going on:
>>>
>>> Everything works except I am getting intermittent audio popping in the 
>>> audio output of the USB sound device.
>>> VERY intermittent maybe about 3-4 'pops' every minute on average.. 10 at 
>>> most sometimes.. and other times several minutes go by without a 'pop'.
>>> It seems to mostly occur during the CW ID beacon which I have going 
>>> every minute..
>>> The pops that are heard only happen when the 'transmitter' is active 
>>> sending PL or CW ID or PLAYBACK...
>>> My test arrangement has "radio key" running to produce continuous PL and 
>>> occasional audio popping.
>>> There is no radio actually hooked up yet.
>>>
>>> OK will talk about the hardware a bit.. and probably worse case scenario 
>>> here due to an 'all in one' motherboard..
>>> It's a MSI 6378 'budget' Athlon board.. everything built on.
>>> Has USB 1.1  *NOT 2*
>>> I don't know/think this matters for a sound device.
>>>
>>> Here's all of the things I have tried all of which have absolutely no 
>>> effect on the intermittent popping...
>>>
>>> 1. Disabling everything not needed on motherboard including ethernet for 
>>> test..
>>>     ethernet + usb share an interrup line and there is no ability to 
>>> re-route this in the bios
>>>     so I turned off the ethernet on the motherboard for testing.
>>>
>>> 2. Carefully monitor CPU during audio pops running 'top' around 20 
>>> updates per second (this alone takes more CPU load than asterisk 
>>> /app_rpt + usb radio.
>>>
>>>
>>> 3. On this motherboard the USB controller and ethernet share a PCI 
>>> interuupt line and you cannot change it.
>>>     I've tried disabling the built on ethernet and still get the popping..
>>>     I've also flood and large pinged the machine which genreates huge 
>>> numbers of interrups from the ethernet chip and this has no effect on 
>>> the popping..
>>>
>>> 4. Tried other USB fobs with same chipset.
>>>     Created various types of heavy system activity to see if it has any 
>>> impact on the popping heavy disk use hevy network use and heavy vga use 
>>> (text mode)
>>>     moving interrupts  (changing them) on the motherboard.. getting usb 
>>> controller onto a different interuupt (ethernet ends up on same).
>>>
>>> 5. Measured and scoped 5V output on USB to be sure 'popping' sound is 
>>> not coming from 5V power supply.
>>>
>>> 6. Am really looking to hear what some others experience has been with 
>>> this..
>>>     what works and what does not?
>>>     The popping very much sounds like an interrupt issue or some kind of 
>>> issue where the task of sending and audio stream is completely dropped 
>>> for something else
>>> and then resumed leaving lots of holes heard as pops in the output stream.
>>>
>>>
>>>       
>>     
> This is reported occasionally, but I've never experienced it.
>
> Given what you've tried already, I'd try a different motherboard.
>
> Also, remove any usb hobs if you are using one.
>
>
> Steve
> WA6ZFT
>
>
>   
Hello David... I *may* also be on to something here as I've been able to 
also determine that the audio pops are occuring ALWAYS
 While app_rpt is doing it's statpost routine!  updating stats via the web.

I set te statpost address to something local on the LAN for now just for 
testing but I get the same audio pops whether just on the
LAN or if it's statposting out to the internet.

The popping definitely happening at the time that app_rpt is sending 
HTTP out..
The popping never happens during other access to-from the ethernet or 
during IAX interchanges between asterisk and the world..
Seems to be only when app_rpt is stat posting...
Dave I think you are certainl correct about the issue being within app_rpt.
I'm sure the stat posting is not the only issue but I can duplicate the 
problem 100% by seeing the popping every time app_rpt
sends out HTTP. :-)

You may have already found that app_rpt does the 'droppouts' with a ton 
of other activities... not just stat posting like I am currently
pointing out...

Might be a start to something though... since it's duplicatable here. :-)

Note: I've not figured out how to manually make it statpost.. I just 
turend up the debug to 7 and waited for it to say it was statposting
also looking at the ethernet and see the HTTP packets go out at same 
time dropous are ocurring.














-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.




More information about the App_rpt-users mailing list