[App_rpt-users] Fwd: Re: ACID install issue anyone seen this before? anyone know the centos default root password?

Steve Gladden steve at michiganbroadband.com
Fri Nov 20 16:14:50 EST 2009


David McGough wrote:
> On Fri, 20 Nov 2009, Steve Gladden wrote:
> <snip>
>   
>> Just as per request and for comparing notes..
>> Digging in deeper reveals the no sources error
>> manually launching phase2 gies a little more detail:
>>
>>
>> make[3]: Leaving directory `/usr/src/zaptel/menuselect/mxml'
>> gcc -o menuselect menuselect.o strcompat.o menuselect_curses.o 
>> mxml/libmxml.a mxml/libmxml.a -lncurses
>> make[2]: Leaving directory `/usr/src/zaptel/menuselect'
>> make[1]: Leaving directory `/usr/src/zaptel/menuselect'
>> Generating input for menuselect ...
>> make[1]: Entering directory `/usr/src/zaptel'
>> echo "You do not appear to have the sources for the 
>> 2.6.18-164.6.1.el5PAE kernel installed."
>> You do not appear to have the sources for the 2.6.18-164.6.1.el5PAE 
>> kernel installed.
>> exit 1
>> make[1]: *** [modules] Error 1
>> make[1]: Leaving directory `/usr/src/zaptel'
>> make: *** [all] Error 2
>> Failure: Unable to compile Zaptel 2
>> Fatal error: Unable to install Asterisk!
>> [root at test rc.d]#
>>
>>
>>
>>     
>
>
> Hi Steve,
>                                                                                                                                                             
> Yes, I had the same problem that the kernel source code wasn't installed
> when I did an ACID install a few months ago. But, this is easy to fix.
> >From a root prompt, just install the package using yum....A command like:
>                                                                                                                                                             
>         yum install kernel-PAE-devel.i686
>                                                                                                                                                             
> Also, I'll upload my "cooked" 2.6.30.5 kernel tonight and send you a link. 
> It should be easy enough to install...
>                                                                                                                                                             
> BTW, I seem to remember needing some other packages, too....But, I don't
> recall which at the moment.
>
>
>                                                                                                                                                             
> 73, David kb4fxc
>                                                                                                                                                             
>
>
>
>   
Way off topic but here's what I'm working on at the moment:
I'm trying to roll a few of my own kernels 


      (2.6.31.6)
      <http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.31.6.tar.bz2>

but keep tripping over myself somehow..
Far as I can tell I have included everything I should need for drives 
and filesystem support yet it won't mount the filesystem.
Having same issue on two systems I tried to make my own kernel for.
I should be able to figure this out.
Don't want to hijack the topic too badly ;-)

One system is the P3 450Mhz box with plain old IDE hard drive.

Other system is Intel Q6700 (2.67Ghz) with NVIDIA SATA (I specifically 
enabled this in kernel tried it with & without it compiled in (generic 
IDE)).
Also having same problem on older IDE only system.
I have to be missing something really basic.
And of course the centos stock kernels are working fine..

Mounting root filesystem. mount: could not find filesystem '/dev/root' 
Setting up other filesystems.
 Setting up new root fs setuproot: moving /dev failed: No such file or 
directory
 no fstab.sys, mounting internal defaults setuproot: error mounting 
/proc: No such file or directory
 setuproot: error mounting /sys: No such file or directory
 Switching to new root and running init. unmounting old /dev unmounting 
old /proc unmounting old /sys switchroot:
 mount failed: No such file or directory Kernel panic - not syncing: 
Attempted to kill init!













-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.




More information about the App_rpt-users mailing list