[App_rpt-users] important update

Jim Duuuude telesistant at hotmail.com
Tue Apr 6 18:08:37 EDT 2010


For a long long long while now, I have had varying reports of
some sort of problem where the rxsquelch setting for chan_usbradio
changes depending on whether you just did a 'radio tune rxnoise'
and then saved it, or you just brouight up chan_usbradio from
its saved configuration. In addition, I myself, have seen cases
where the RSSI and squelch values seemed just really silly
high for some reason.

I believe I have found the culprit and have fixed it. It turns out
that the hardware gain of the USB sound chip was different
depending on whether it just had a 'tune rxnoise' or if it
was set up from the config file. It turns out that because
of a rounding error, it would often set its value 1 too low
(compared with what the 'tune rxnoise' calculated it
should have been). Believe me, when you only get a range
of 1 to 16, 1 too low makes a big difference (about 1.5 db)!!
This has now been fixed in the new version of chan_usbradio
that will appear on the SVN this afternoon after about 3:30 PM PDT.

Also, because of changes made in the squelch processing
a few months ago (hysteresis was added), the squelch
turn-off point is at least 60 'RSSI units' (whatever they are)
higher then the signal level. Its probably a good idea to set
the rxsquelch level to 80-100 higher then the level with no
signal.

This should both fix and explain a lot of strange things going on.
I dont think this deals with some of the weirdness with 12.5
kHz receivers, but it might at least help in this area.

JIM WB6NIL




 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20100406/7ce9d697/attachment.html>


More information about the App_rpt-users mailing list