[App_rpt-users] iax / Asterisk & I should never be called

Ken ke2n at cs.com
Sat Jan 1 23:08:04 EST 2011


No replies on this one - yet

 

Let me add one thing - if I try to connect to the node on port 4569 while
the one on port 4568 is already connected, iaxRpt gives an error message
about the  node already being active and refuses to attempt the connection.

 

So I am sort of concluding that iaxRpt cannot handle a case where there are
two nodes on different ports at the same IP address.  I am (slightly)
surprised that the one that works is the higher-numbered node on the
non-standard port, but given the messages that app_rpt is throwing off
(below), it's clear that chan_iax.c and channel.c are working in some sort
of goofball mode anyhow and I am just lucky that it fails in a way to yield
a working connection  (these are versions 266 and 267, incidentally).

 

Has anyone else tried iaxRpt on  an asterisk system with two nodes behind a
common router?

 

Ken

 

 

From: Ken [mailto:ke2n at cs.com] 
Sent: Friday, December 31, 2010 12:09 PM
To: 'app_rpt-users at ohnosec.org'
Subject: iax / Asterisk & I should never be called

 

Been scratching my head here for a week with iaxRpt. 

 

I have two nodes: I can connect to one of them (so iaxRpt is obviously
working) but not the other

 

App-rpt  is trying to tell me something about the problem but I do not know
what:

 

atom2*CLI>

    -- Accepting AUTHENTICATED call from 69.243.53.147:

       > requested format = ulaw,

       > requested prefs = (),

       > actual format = ulaw,

       > host prefs = (ulaw|gsm),

       > priority = mine

    -- Executing [27021 at radio-gui:1] Rpt("IAX2/gui-126", "(27021|X)") in new
stack

[Dec 31 11:39:13] WARNING[1555]: app_rpt.c:20884 rpt_exec: Cannot find
specified system node (27021

  == Spawn extension (radio-gui, 27021, 1) exited non-zero on 'IAX2/gui-126'

    -- Hungup 'IAX2/gui-126'

 

I have looked at iax.conf and extensions.conf and do not see any differences
between the two nodes, other than the node numbers.

I am connecting from behind the same router. 

The node that works is on port 4568 (on the internet side) and the one that
does not work is on port 4569.

The one that works can connect both on the local IP address and on the WAN
address with the 4568 port number appended.

I have tried making the iaxRpt "listener port 4567, "just for grins" - no
effect.

 

>>>>> Why can't app-rtp find it *own* node number when called by iaxRpt?

 

Here is what it looks like when it works (the other node):

 

-- Accepting AUTHENTICATED call from 69.243.53.147:

       > requested format = gsm,

       > requested prefs = (),

       > actual format = gsm,

       > host prefs = (gsm),

       > priority = mine

    -- Executing [27061 at radio-gui:1] Rpt("IAX2/gui-6459", "27061|X") in new
stack

[Dec 31 12:02:43] NOTICE[22711]: channel.c:2075 __ast_read: No/unknown event
'0' on timer for 'IAX2/gui-6459'?

[Dec 31 12:02:43] NOTICE[22711]: chan_iax2.c:4677 iax2_read: I should never
be called!

  == Spawn extension (radio-gui, 27061, 1) exited KEEPALIVE on
'IAX2/gui-6459'

    -- <Zap/pseudo-363503172 ((all the callsign readouts here))

    -- Hungup 'Zap/pseudo-363503172'

    -- Hungup 'Zap/pseudo-135650357'

 

The "I should never be called" message looks like something gone wrong in
app-rpt .. except that it works.

 

Ken

 

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20110101/8ab0af39/attachment.html>


More information about the App_rpt-users mailing list