[App_rpt-users] Audio gateway issues??

Matt Beasant g4rky at yahoo.co.uk
Fri Jan 14 16:27:29 EST 2011


In case anyone is interested....
I have scripted a solution that is currently acceptable to Dave Cameron and
Dave Gingrinch of IRLP fame,  as an interim solution - this allows me to
keep my allstar node functioning with IRLP while I try and devise a solution
to keep my 2 IRLP nodes "alive", currently running within Allstar.

Basically it uses the connect and disconnect scripts (that used to tweet the
repeater status) to determine if an IRLP node is connecting. If it is an
IRLP node, then the "No Incoming mode" is selected, stopping any
crosslinking to Echolink or other Allstar nodes. This doesnt affect the
existing Allstar connections in use to link my repeaters together, which is
why its difficult for me to use traditional IRLP nodes.

If an additional Allstar node or Echolink node connects, the script deletes
the "enable" file from the IRLP/Local directory, thereby disabling the IRLP
node and stopping any incoming or outgoing IRLP connections for the
duration. Once the other node disconnects the "enable" file is restored,
enabling the IRLP node once more.

I've done this externally to the Allstar code as I dont know how to code it
within the applcation but I am sure it would be possible to code a solution
to keep the IRLP folk happy and with inherent flexibility within Allstar, it
could be enabled and disabled as required.

I can't emphasise enough how great it would be if we could have IRLP back as
an integral part of Allstar - is it dead forever? I hope not.

Matt
G4RKY
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20110114/27a928f0/attachment.html>


More information about the App_rpt-users mailing list