[App_rpt-users] Beagleboard URI issue: "device usb27674 currently not active"

Phil N6TCT phil.n6tct at gmail.com
Sat Mar 5 18:37:17 EST 2011


Gang, I would love whatever help your collective brains and experience
can provide on the following newbie problem.

I recently brought up a generic PC running ACID and a USB URI fob and
made it all work.  Yay!  Emboldened by my success :-) I thought I
would try getting my beagleboard running in a similar configuration
... and so far, failed.  The URI green LED blinks like it should when
asterisk starts.  But asterisk CLI "radio key" and "radio unkey" don't
do anything (i.e., they do not turn on or off the URI fob's red LED).
Attempting to run "radio tune txvoice 500" generates the error "Device
usb27674 currently not active".  (27674, of course, is the node number
for this system.)  Running "radio active usb27674" does not give an
error but does not change anything (i.e., radio tune still fails with
the same error message).

I suspect it is just some simple configuration thing I have overlooked
and would greatly appreciate any thoughts.  --Phil, N6TCT

Details:

Beagleboard hardware is a beagleboard-xM, assy rev B, at 1 GHz.

OS is pickle linux:  Linux version 2.6.35.4 (root at pickle) (gcc version
4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #5 PREEMPT Wed Dec 29 04:03:36 UTC
2010 ()

URI is a DMK URI; I have two of them and have tried both of them, same
behavior.  Both work fine on my PC system.

Asterisk configuration: I first downloaded files from the allstar link
network and then modified by hand to use the simpleusb channel.  I
have included my usbradio.conf, simpleusb.conf, and rpt.conf below.
(Is it true that I actually need both usbradio.conf and
simpleusb.conf?)

When the system boots it finds the URI:

[   68.294250] generic-usb 0003:0D8C:013C.0002: input: USB HID v1.00
Device [C-Media Electronics Inc.       USB PnP Sound Device          ]
on usb-ehci-omap.0-2.4/input3

When asterisk starts it logs messages I would expect (esp. since I
can't tune the radio):

[Mar  5 23:14:00] NOTICE[775] app_rpt.c: Normal Repeater Init  27674
[Mar  5 23:14:00] NOTICE[793] chan_simpleusb.c: Assigned USB device 1-2.4:1.0 to
 simpleusb channel usb27674
[Mar  5 23:14:00] WARNING[793] chan_simpleusb.c: File simpleusb_tune_usb27674.co
nf not found, device usb27674 using default parameters.

As mentioned, radio key and radio unkey do not give errors but neither
do they do anything on the URI fob.  Radio tune gives an error:

peekskill*CLI> radio active
Active (command) USB Radio device is [usb27674]
peekskill*CLI> radio key                               <-- note no error
peekskill*CLI> radio unkey                             <-- note no error
peekskill*CLI> radio tune txvoice 500
Device usb27674 currently not active
peekskill*CLI> radio active
Active (command) USB Radio device is [usb27674]
peekskill*CLI> radio active usb27674
Active (command) USB Radio device set to [usb27674]
peekskill*CLI> radio tune txvoice 500
Device usb27674 currently not active

The start of my rpt.conf file:

[27674]                                 ; Change this to your assigned
node number

rxchannel=SimpleUSB/usb27674
duplex=2
erxgain=-3
etxgain=3
;controlstates=controlstates
[...]

My usbradio.conf:

;
; Usbradio channel driver Configuration File
;

[general]

[usb27674]

hdwtype=0
rxboost=1
txboost=1
rxctcssrelax=1
txctcssdefault=100.0
rxctcssfreqs=100.0
txctcssfreqs=100.0
;rxctcssoverride=0
carrierfrom=usbinvert
ctcssfrom=no
rxdemod=speaker
txprelim=no
txlimonly=no
txtoctype=notone
txmixa=voice
txmixb=no
invertptt=0
duplex=1
rxondelay=0
rxnoisefiltype=0
eeprom=0
#includeifexists custom/usbradio.conf

My simpleusb.conf:


;
; SimpleUSB configuration
;
[general]

[usb27674]

eeprom=0

hdwtype=0               ; Leave this set to 0 for USB sound fobs modified using
                       ; the instructions from usbfob.pdf. Use a setting of
                       ; 1 is for Dingotel/Sph interfaces.

rxboost=1               ; 0 = 20db attenuator inserted, 1= 20db attenuator remov
ed
                       ; Set to 1 for additonal gain if using a low-level receiv
er output

carrierfrom=usbinvert   ; no,usb,usbinvert
                       ; no - no carrier detection at all
                       ; usb - from the COR line on the modified USB sound fob
                       ; usbinvert - from the inverted COR line on the modified
USB sound fob

ctcssfrom=no            ; no,usb,usbinvert
                       ; no - CTCSS decoding, system will be carrier squelch
                       ; usb - CTCSS decoding using input from USB FOB
                       ; usbinvert - from the inverted CTCSS line on the modifie
d USB sound fob

txmixa=voice            ; Left channel output: no,voice,tone,composite,auxvoice
                       ; no - Do not output anything
                       ; voice - output voice only

txmixb=no               ; Right channel output: no,voice,tone,composite, auxvoic
e
                       ; See txmixa above.

invertptt=0             ; Invert PTT 0 = ground to transmit, 1 = open to transmi
t
                       ; This is the collector lead of the 2n4401 on the modifie
d
                       ; usb sound fob.
                       ; please refer to the howto for the procedure to do this.
duplex=1                ; Full Duplex

plfilter=yes            ; enable PL filter

deemphasis=no           ; enable de-emphasis (input from discriminator)

Thanks!

Phil, N6TCT



More information about the App_rpt-users mailing list