[App_rpt-users] Network Driver

Doug Bade kd8b at thebades.net
Sun Mar 13 14:47:32 EDT 2011


Steve;
I would suspect you need a lot of support files to do the make that are 
not on the computer to compile it..

The quickest fix I found for Atom boards that do not have ethernet chips 
that are recognized by the CentOS install is to buy a Linksys USB 
ethernet dongle from your local staples, best buy or whatever and plug 
it in. CentOS recognizes it and after you finish the build, your 
on-board will also be recognized. You can then remove the usb and 
configure the on-board as needed.. It is a $30.00 fix but if you play in 
Linux, it is not unusual the new motherboards have network chipsets that 
will be supported but many times are not in the installation CD's..

Your alternate plan is install all the build resources needed to be able 
to run make... but that will probably require a working network 
connection to download all that :-) You  can bring them all in via usb 
thumb drive or such.. but I think the usb network device will get the 
job done most painlessly !! Albeit at addition hardware cost.

Doug
KD8B




On 3/13/2011 1:58 PM, Steve Schulze wrote:
> I'm installing a new node (27727) onto a new PC. I thought I would try 
> a Shuttle XS35-704. Nice little machine with the 1.66 Atom processor, 
> 2GB ram and 320GB HDD.
>
> Using the ISO I used to build node 27616, I run the setup on the new 
> machine.
>
> When it got to the first reboot, it indicated that it did not have 
> internet connectivity and could not continue.
>
> Used interactive startup and didn't load 'firstboot' and 'local' so I 
> could get a prompt. Logged in as root and run setup to take a look at 
> the network settings. Low and behold the network card was not there.
>
> After many hours searching the internet for answers for loading 
> drivers from the command prompt, I was able to find the driver for the 
> built-in NIC. A JMC260 PCI Express Fast Ethernet Controller.
>
> Of course, I found many suggestions on how to load this driver 
> however, I'm not having any luck.
>
> I downloaded the driver JME-1.0.7.1.tbz2 and did the following:
>
> # tar xjvf jme-1.0.7.1.tbz2     ;worked fine, no problem.
>
>
> Changed to the directory where the decompression took place and then
>
> # make install     ;this is where it failed. I get the following error:
>
> make: *** /lib2/modules/2.6.18-194.el5/build: No such file or 
> directory. Stop.
> make: *** [all] Error 2
>
>
> Would this be a result of not having a complete install of the OS at 
> this stage?
>
>
> Looking for some insight on how to install this driver.
>
>
> BTW, prior to installing the Acid ISO, I had installed the XIPPR ISO 
> 'xosipt_20100518_1438.iso' and the network card worked fine. I wanted 
> to evaluate the XIPPR before installing ACID.
>
>
>
> Thanks!
>




More information about the App_rpt-users mailing list