[App_rpt-users] IAX registration problems

David KE6UPI dshaw at ke6upi.com
Tue Mar 22 20:52:09 EDT 2011


I tried to connect and no go. Maybe it was rebooting?

asl2063*CLI> rpt fun 2063 *32335
  == Parsing '/var/lib/asterisk/rpt_extnodes': Found
  == Parsing '/var/lib/asterisk/rpt_extnodes': Found
  == Parsing '/var/lib/asterisk/rpt_extnodes': Found
  == Parsing '/var/lib/asterisk/rpt_extnodes': Found
  == Parsing '/var/lib/asterisk/rpt_extnodes': Found
    -- Call accepted by 70.90.228.195 (format ulaw)
    -- Format for call is ulaw
    -- Hungup 'IAX2/70.90.228.195:4570-747'
    -- Hungup 'Zap/pseudo-2145599652'
    -- Hungup 'Zap/pseudo-1922206398'
    -- <Zap/pseudo-103960313> Playing 'rpt/node' (language 'en')
    -- <Zap/pseudo-103960313> Playing 'digits/2' (language 'en')
    -- <Zap/pseudo-103960313> Playing 'digits/3' (language 'en')
    -- <Zap/pseudo-103960313> Playing 'digits/3' (language 'en')
    -- <Zap/pseudo-103960313> Playing 'digits/5' (language 'en')
    -- <Zap/pseudo-103960313> Playing 'rpt/connection_failed' (language
'en')
    -- Hungup 'Zap/pseudo-103960313'

On Tue, Mar 22, 2011 at 8:50 PM, Stephen - K1LNX <k1lnx at k1lnx.net> wrote:

> Weird.... ok rather than second guess it, I'm going to blow away that file
> and reboot to get a fresh copy. It's undoubtedly making it to the rest of
> the nodes :)
>
> On Tue, Mar 22, 2011 at 8:48 PM, David KE6UPI <dshaw at ke6upi.com> wrote:
>
>> I show you using port 4570 and IP address .195.
>>
>> [root at asl2063 ~]# cat /var/lib/asterisk/rpt_extnodes | grep 2335
>> 2335=radio at 70.90.228.195:4570/2335,70.90.228.195
>>
>> So it looks good now?
>>
>> David
>>
>>
>> On Tue, Mar 22, 2011 at 8:45 PM, Stephen - K1LNX <k1lnx at k1lnx.net> wrote:
>>
>>> Thanks... for clarification, I have 5 static IP's from my provider. 4 of
>>> them live on one router (an atom based server running pfSense), the .196
>>> sits on a seperate wireless router, completely isolated from everything
>>> else. It was cabled to that previously, but I moved it off of there as it
>>> was only there for temporary testing.
>>>
>>> > Did you configure the allstarlink server that you are using 4570?
>>>
>>> Yes, in the networking config section of the portal the port is set to
>>> 4570 and I have "custom (IP config set on VoIP server)" set in the dropdown
>>> menu. My theory is that once I have registered on the new IP it should have
>>> updated accordingly, I have restarted asterisk, rebooted, etc. and no luck
>>> :/
>>>
>>> My guess at this point is maybe that it's cached at the allstar server
>>> end and expires after a pre-determined length of time when an IP changes.
>>> Still can't put a finger on the port thing though...
>>>
>>>
>>> On Tue, Mar 22, 2011 at 8:34 PM, David KE6UPI <dshaw at ke6upi.com> wrote:
>>>
>>>> As for the public router address that would something to take up with
>>>> your ISP. I would check it by using http://whatismyip.com.
>>>> Here is my registry. I do use 4570. Did you configure the allstarlink
>>>> server that you are using 4570?
>>>>
>>>> asl2063*CLI> iax2 show registry
>>>>
>>>> Host                  dnsmgr  Username    Perceived             Refresh
>>>> State
>>>> 67.215.233.178:4569   N       2081        72.67.127.136:4570
>>>> 60  Registered
>>>> 67.215.233.178:4569   N       2080        72.67.127.136:4570
>>>> 60  Registered
>>>> 67.215.233.178:4569   N       2064        72.67.127.136:4570
>>>> 60  Registered
>>>> 67.215.233.178:4569   N       2063        72.67.127.136:4570
>>>> 60  Registered
>>>>
>>>> David
>>>>
>>>>
>>>> On Tue, Mar 22, 2011 at 8:18 PM, Stephen - K1LNX <k1lnx at k1lnx.net>wrote:
>>>>
>>>>> That's part of my issue, my 70.90.228.196 address is on an entirely
>>>>> different router, I am attempting to use 70.90.228.195 as my registered
>>>>> address, and unless I'm not looking at it correctly it is using port 4569
>>>>> instead of 4570. If someone attempts to connect to me it will fail in it's
>>>>> current state.
>>>>>
>>>>>
>>>>>
>>>>> On Tue, Mar 22, 2011 at 8:10 PM, David KE6UPI <dshaw at ke6upi.com>wrote:
>>>>>
>>>>>> Well the server you are connected too is using port 4569. I bet if a
>>>>>> node connect to you they would use port 4570.
>>>>>>
>>>>>> David
>>>>>>
>>>>>> On Tue, Mar 22, 2011 at 7:47 PM, Stephen - K1LNX <k1lnx at k1lnx.net>wrote:
>>>>>>
>>>>>>> Ok... where am I going wrong? Running ACID, self managed server (not
>>>>>>> portal managed) and I can not get Asterisk to register to the registration
>>>>>>> server correctly. I am attempting to use port 4570 and set bindport=4570 in
>>>>>>> iax.conf.
>>>>>>>
>>>>>>> If I do an iax2 show registry:
>>>>>>> allstar*CLI> iax2 show registry
>>>>>>> Host                  dnsmgr  Username    Perceived
>>>>>>> Refresh  State
>>>>>>> 67.215.233.178:4569   N       2335        70.90.228.195:4569
>>>>>>> 60  Registered
>>>>>>>
>>>>>>> It show registered, but not on the correct port ???
>>>>>>>
>>>>>>> I also show the entry in /var/lib/asterisk/rpt_extnodes to be
>>>>>>> incorrect, it shows the IP I was previously using:
>>>>>>> [root at allstar asterisk]# cat /var/lib/asterisk/rpt_extnodes | grep
>>>>>>> 2335
>>>>>>> 2335=radio at 70.90.228.196:4570/2335,70.90.228.196
>>>>>>>
>>>>>>> Anyone have any ideas? I've been off the air for a while due to
>>>>>>> hardware issues, and these configs were working previously, but it's
>>>>>>> probably been a year or more.....
>>>>>>>
>>>>>>> tnx and 73,
>>>>>>> Stephen
>>>>>>>
>>>>>>> --
>>>>>>> ****************************************
>>>>>>> Stephen Brown - ARS K1LNX
>>>>>>> Johnson City, TN EM86
>>>>>>> http://www.k1lnx.net
>>>>>>> Allstar Link: 2335
>>>>>>> IRLP: 4829
>>>>>>> PSTN: 423-665-9367
>>>>>>> SIP: k1lnx at k1lnx.net
>>>>>>> ****************************************
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> App_rpt-users mailing list
>>>>>>> App_rpt-users at ohnosec.org
>>>>>>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> ****************************************
>>>>> Stephen Brown - ARS K1LNX
>>>>> Johnson City, TN EM86
>>>>> http://www.k1lnx.net
>>>>> Allstar Link: 2335
>>>>> IRLP: 4829
>>>>> PSTN: 423-665-9367
>>>>> SIP: k1lnx at k1lnx.net
>>>>> ****************************************
>>>>>
>>>>> _______________________________________________
>>>>> App_rpt-users mailing list
>>>>> App_rpt-users at ohnosec.org
>>>>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>>>>>
>>>>>
>>>>
>>>
>>>
>>> --
>>> ****************************************
>>> Stephen Brown - ARS K1LNX
>>> Johnson City, TN EM86
>>> http://www.k1lnx.net
>>> Allstar Link: 2335
>>> IRLP: 4829
>>> PSTN: 423-665-9367
>>> SIP: k1lnx at k1lnx.net
>>> ****************************************
>>>
>>> _______________________________________________
>>> App_rpt-users mailing list
>>> App_rpt-users at ohnosec.org
>>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>>>
>>>
>>
>
>
> --
> ****************************************
> Stephen Brown - ARS K1LNX
> Johnson City, TN EM86
> http://www.k1lnx.net
> Allstar Link: 2335
> IRLP: 4829
> PSTN: 423-665-9367
> SIP: k1lnx at k1lnx.net
> ****************************************
>
> _______________________________________________
> App_rpt-users mailing list
> App_rpt-users at ohnosec.org
> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20110322/e6c662c6/attachment.html>


More information about the App_rpt-users mailing list