[App_rpt-users] Debugging COS

Jim Whiteside jaydublu2002 at gmail.com
Sun Feb 12 07:34:21 EST 2012


> Assuming COS is connected to the Volume Down pin on the CM108 then how
about
> plugging the fob into another PC which is not running the Asterisk drivers
> and see if the volume control is affected when COS is asserted?

> On my PC, if I press volume down, either on the keyboard or on an
unmodified
> USB sound fob then a volume bar pops up in the centre of the screen.  It's
> very visible.

> Naturally, there may be a 'correct' way to do this with some sort of
built-in
> diagnostics...

> 73,

> Andrew
> ZL3AME

That's a good plan.

So I take an unmodified fob, that does have volume buttons on, and plug it
into a PC. 'volume down' button does indeed trigger the windows volume bar.
But this fob and button don't do anything on Asterisk.

My modified fob - taking pin 48 to gnd also triggers the volume down on
Windows, so that suggests it's not hardware?

Jim M0HPJ

On 12 February 2012 11:45, Jim Whiteside <jaydublu2002 at gmail.com> wrote:

> I'm still chipping away at modifying a Startech CM108 USB fob - so far I
> have successfully got PTT and audio out working, but I'm struggling with
> audio in and COS.
>
> I've been following http://www.qsl.net/k0kn/cm108_mod.html
>
> Can anyone advise if there's a way to determine from the Asterisk side if
> COS is active or not?
>
> I've even tried manually taking the CM108 pin 48 to 0v and +5v with the
> iax.conf below, but I can't seem to make anything 'happen'.
>
> My theory was, as soon as I have COS triggering Asterisk correctly, then I
> can look at getting the audio in working properly.
>
> TIA
>
> --
> Jim Whiteside.
> M0HPJ
>
> [usb28233]
> hdwtype=0
> rxboost=1
> txboost=0
> rxctcssrelax=1
> txctcssdefault=94.8
> rxctcssfreqs=94.8
> txctcssfreqs=94.8
> ;rxctcssoverride=0
> carrierfrom=usbinvert
> ctcssfrom=no
> rxdemod=speaker
> txprelim=no
> txlimonly=no
> txtoctype=notone
> txmixa=composite
> txmixb=no
> invertptt=0
> duplex=0
> rxondelay=0
> rxnoisefiltype=0
> eeprom=0
>



-- 
Jim Whiteside.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20120212/01c2a9c1/attachment.html>


More information about the App_rpt-users mailing list