[App_rpt-users] cor active PL logic

Fredric Moses fred at moses.bz
Mon Jan 2 01:00:56 EST 2012


Yea i added the txpl stuff into my beagle.conf file and got nota outa the soundcard.. Even connected to my audio display board directly got no PL generation...  I am going to order some nice USB adapters and just run the repeater off that connected to it.. as it looks like the internal PL generation will do what we be a looking for...  Just means I order some now.. was going to anyways to add more ports to the BeagleboardXM here sooner or later.. Have all my current macros re-wrote and tested this was the last part of the puzzle..   Should have done this months ago.. Could have swapped out some of my other repeaters.. being winter some of my other sites are hard to get to without snow shoes..  but once spring comes around or I get bored and wana snow shoe for fun. they will wait...

I was trying to make the controller swap out as transparent to the users and other repeaters that link in to me via RF as possible and cor/active PL is a feature that is one used ALOT. myself included on my office radio..

I have it working with cop,61 now.. but only for local ports.. if traffic comes in from a remote node there is no variable to follow so it doesn't change..

Thanks again...
--
Fredric Moses - W8FSM - WQOG498
fred at moses.bz




On Jan 2, 2012, at 12:33 AM, Monty wrote:

> I believe it is for the generated tone from app_rpt.  I have not used a Beagleboard as of yet, maybe someone who has could let us know.  I would imagine instead of cop 58 and 59 you would use 61 to manipulate, see http://ohnosec.org/drupal/node/177.  Try this:
> 
> [functions]
> 900 = cop,61,GPIO1=1        ;Tx CTCSS On Input only Enable (High)
> 901 = cop,61,GPIO1=0        ;Tx CTCSS On Input only Disable (Low)
> 
> 
> Monty
> 
> 
> On Sun, Jan 1, 2012 at 9:22 PM, Fredric Moses <fred at moses.bz> wrote:
> Thanks for the reply monty..  But when I enable this is it controlling a logic gpio. or is it controlling the PL freq generated into the audio audio out...  I am using the beagleboard/lox combo which i was under the impression needed external decode and encode of pl's.. Unlike the usb interface from dmkeng...
> 
> --
> Fredric Moses - W8FSM - WQOG498
> fred at moses.bz
> 
> 
> 
> 
> On Jan 1, 2012, at 11:19 PM, Monty wrote:
> 
>> Hi Fredric,
>> That command list was pulled from the source app_rpt.c and the asterisks are to comment those lines out.  To excute those commands you will need to create a function.  I put them under [functions] in /etc/asterisk/rpt.conf.  For example:
>> 
>> [functions]
>> 900 = cop,58        ;Tx CTCSS On Input only Enable
>> 901 = cop,59        ;Tx CTCSS On Input only Disable
>> 
>> A *900 will execute TX CTCSS Enable, *901 will execute TX CTCSS Disable.
>> 
>> Also Allstarnode.com is not maintained by the developers of app_rpt, it is a third party site.  The current site for configuration information is http://ohnosec.org/drupal.  The variable you are looking for is documented at http://ohnosec.org/drupal/node/176.
>> 
>> 
>> Monty
>> 
>> 
>> On Sun, Jan 1, 2012 at 2:04 AM, Fredric Moses <fred at moses.bz> wrote:
>> I am working on getting a logic output to run my PL encoder for COR active PL on the main repeater port.  using a variable i was able to get it to work fine with local RX audio. When a signal is present I have a gpio pin going low.. when not present going back high..   but can not find a variable to watch for IP links coming in. Is there one?  Is there something I can watch so that I can make the logic pin swing..?
>> 
>> Some google foo found these commands
>> * 56 - Rx CTCSS Enable
>> * 57 - Rx CTCSS Disable
>> * 58 - Tx CTCSS On Input only Enable
>> * 59 - Tx CTCSS On Input only Disable
>> http://allstarnode.com/viewtopic.php?f=5&t=8
>> 
>> The only mention I see of TX PL is with use of a USB radio interface.  Will *58 follow the tx pl settings set in usbradio if I had a USB radio device vs using one of the LOX ports for the main repeater..
>> 
>> --
>> Fredric Moses - W8FSM - WQOG498
>> fred at moses.bz
>> 
>> 
>> 
>> 
>> _______________________________________________
>> App_rpt-users mailing list
>> App_rpt-users at ohnosec.org
>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>> 
> 
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20120102/56ae3b6d/attachment.html>


More information about the App_rpt-users mailing list