[App_rpt-users] USB Soundcard Fob - no audio

Corey Dean n3fe at repeater.net
Fri Jan 6 09:41:19 EST 2012


Is the radio transmitting or is it just transmitting with no audio?  Have to tried using the other channel?  If you are using the left side have you tried the right side?

Corey N3FE
________________________________________
From: app_rpt-users-bounces at ohnosec.org [app_rpt-users-bounces at ohnosec.org] On Behalf Of Jim Whiteside [jaydublu2002 at gmail.com]
Sent: Friday, January 06, 2012 9:29 AM
To: app_rpt-users at ohnosec.org
Cc: George Csahanin
Subject: Re: [App_rpt-users] USB Soundcard Fob - no audio

George,

Thanks for the reply.

txmixa was set to 'composite', txmixb to '0' - changing this also to
composite didn't make a difference. Do you know what

asterisk*CLI> radio tune txvoice
Current txvoice setting on Channel A is 500
Tone output starting on channel usb28233...
Tone output ending on channel usb28233...
asterisk*CLI> radio tune txtone
Current Tx CTCSS modulation setting = 200

Neither of the above did anything.

If I copnnect to the node using IaxRpt, *80 ID's fine from that
application, but not from the fob. Also I can connect to another node
and have a QSO using IaxRpt, but again nothing from the fob.

I'm plugging stereo headphones into the fob headphone jack.

Interesting advice about using LPT for the GPIO - I might pick your
brains about that if I can get the audio working - I'd rather avoid
the expense of buying in URI - the shipping is almost as much as the
device to the UK, and I'd like the challenge of working it out.

Cheers,

Jim M0HPJ.

On 6 January 2012 13:51, George Csahanin <george at dyb.com> wrote:
>
> The flashing green light is a good sign.
>
> That's reporting in as a CM108 for sure.
>
> From the source code:
> #define C108_VENDOR_ID 0x0d8c
> #define C108_PRODUCT_ID 0x000c
>
> In usbradio.conf make sure that txmixa= and txmixb= something other than no
>
> Example from one of my nodes:
>
> txmixa=composite        ;no,voice,tone,composite,auxvoice
> txmixb=composite
>
> also try (from asterisk command line) "radio tune"
>
> From my 2360 node:
> ...
> Tx Voice Level currently set to 350
> Tx Tone Level currently set to 160...
>
> If those are too low you might not get anything out.
>
> ALSO...to transmit tone "radio tune txvoice" should put out a tone.
>
> *80 (default setup) makes the thing ID, and if that isn't setup correctly
> might give you no audio.
>
> Another point is that I no longer modify USB Fobs. The ones I use are
> identical to the ones in that pdf. But I use the PC's parallel port lines
> for COS in and PTT out, much neater.
> I also do DC blocking (the caps) in the radio.
>
>
>
> ----- Original Message ----- From: "Jim Whiteside" <jaydublu2002 at gmail.com>
> To: <app_rpt-users at ohnosec.org>
> Sent: Friday, January 06, 2012 5:34 AM
>
> Subject: [App_rpt-users] USB Soundcard Fob - no audio
>
>
>> I'm working hard to get a basic AllStar system running, and struggling
>> to find a suitable USB Fob to modify (trying to do it on a budget)
>>
>> I've been unable to get hold of the exact model shown in
>> www.qsl.net/kb9mwr/projects/voip/usbfob-119.pdf, but now have several
>> of a very similar one with the printed description 'Virtual 7.1Ch
>> Sound' and a slightly translucent case.
>>
>> lsusb reports the device as 'ID 0d8c:000c C-Media Electronics, Inc.
>> Audio Adapter.' which I think might be CM119 or similar.
>>
>> When plugged in the green led starts to flash, but I've not yet been
>> able to get any audio out of it - even when running 'rpt fun <node>
>> *80' from the Asterisk CLI
>>
>> I wanted to confirm this was a suitable fob before going to the grief
>> of modifying - it's much more SMT than in the above PDF, and you can't
>> actually access the pins on the chip itself as it's under a 'bubble'
>> of a ceramic compound.
>>
>> Any advice would be gratefully received.
>>
>> --
>> Jim M0HPJ.
>>
>>
>



--
Jim Whiteside.
_______________________________________________
App_rpt-users mailing list
App_rpt-users at ohnosec.org
http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users

--
This message was scanned and is believed to be clean.
Click here to report this message as spam.
http://simba.repeater.net/cgi-bin/learn-msg.cgi?id=92FD1221F.A8D38


More information about the App_rpt-users mailing list