[App_rpt-users] EchoLink

Alan Adamson adamson_alan at hotmail.com
Wed May 23 15:59:02 EDT 2012


if you are talking about the UDP ports (5198 and 5199), then yes, but this would be a TCP issue as I'm sure there is some connection that is made (outbound from me to a registration server) and that I would assume would be on a TCP connection… Outbound connections are not blocked by my router and I have the UDP ports forwarded as noted above and still the same error responses.
 
 
 
From: Matt Roberts [mailto:n9gmr at me.com] 
Sent: Wednesday, May 23, 2012 3:15 PM
To: Alan Adamson
Subject: Re: [App_rpt-users] EchoLink
 
Did you forward the required ports in your router?
Matt Roberts
n9gmr at me.com
 
Sent from my iPhone

On May 23, 2012, at 2:22 PM, Alan Adamson <adamson_alan at hotmail.com> wrote:
Doesn't get much easier than this… straight from the samples config file with the information changed as required.
 
[el0]
confmode=no
call=W7QO-R            ; Change this!
pwd=<changed to my password>               ; Change this!
name=Test ; Change this to your real name!
qth=Atlanta,GA ; Change this to your actual QTH!
email=adamson_alan at hotmail.com ; Change this!
maxstns=20
rtcptimeout=10
node=710254 ; Change this!
recfile=/tmp/recorded.gsm
astnode=28578 ; Change this to your active Allstar node number!
context=radio-secure
server1=server1.echolink.org
server2=server2.echolink.org
server3=server3.echolink.org
 
With that setup I get these errors which have been discussed before… and it doesn't matter if I change the server names to naeast.echolink.org, etc.
 
[May 23 14:19:52] ERROR[2033] chan_echolink.c: Error in parsing header on server1.echolink.org
[May 23 14:20:22] ERROR[2031] chan_echolink.c: connect() failed to connect to the Echolink server server2.echolink.org
[May 23 14:20:22] ERROR[2033] chan_echolink.c: connect() failed to connect to the Echolink server server2.echolink.org
[May 23 14:20:43] ERROR[2033] chan_echolink.c: Unable to connect to directory server server2.echolink.org
[May 23 14:20:43] ERROR[2033] chan_echolink.c: Error in parsing header on server3.echolink.org
[May 23 14:21:03] ERROR[2033] chan_echolink.c: Error in parsing header on server1.echolink.org
 
I'll go look to see if there have been changes to the chan_echolink.c file that I'm not running but I just built everything with the distribution makefile yesterday.  This was talked about on this forum last year, but I never found a resolution other than it worked for some and not for others…???
 
Alan
 
From: Ken [mailto:ke2n at cs.com] 
Sent: Wednesday, May 23, 2012 1:23 PM
To: adamson_alan at hotmail.com
Subject: Re: [App_rpt-users] EchoLink
 
It is not unusual for one of the echolink servers to be down;  as long as you can talk to *one* of them, it should work.
I think that, after you come on line, it may be some time before you can actually USE the echolink feature, while you wait for their system to updpate.
Incorrect header information is another story - if you post your configuration (minus the password) maybe someone will see a problem - or not - in which case there was some compile issue ...
 
Ken
-----Original Message-----
From: Alan Adamson <adamson_alan at hotmail.com>
To: App_rpt-users <App_rpt-users at ohnosec.org>
Sent: Wed, May 23, 2012 8:34 am
Subject: [App_rpt-users] EchoLink
So, learning to run before I can walk :)…  With my newfound enthusiasm and a debian install.  I wanted to test out functionality figured an easy way was to see about getting EchoLink working as well.
So I added the echolink.conf file, made the changes for my specific EchoLink node and restarted.  However I get all these errors about not being able to connect to their servers, header information not being correct, etc.  
I did some scanning and found that others have experiences the same thing.  Anyone have this working on a recent install?
Second, is there some type of *echo* conference bridge or *reflector* (Sorry for the use of the term, but it's appropriate)… I need some way to test audio without being live on the air, etc?
Alan
_______________________________________________
App_rpt-users mailing list
App_rpt-users at ohnosec.org
http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
_______________________________________________
App_rpt-users mailing list
App_rpt-users at ohnosec.org
http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20120523/b69229f4/attachment.html>


More information about the App_rpt-users mailing list