[App_rpt-users] Using SVN copy of Asterisk on RaspberryPi (and "usb.h")

Shane Morris edgecomberts at gmail.com
Fri Oct 26 22:43:25 EDT 2012


Hi mate!

I've had Real Life (TM) intervene in the meantime since my last email,
and I've not been able to invest any time in the project.

Additionally, theres not been any responses to my post on the RPi
forums regards the information I need to get the kernel sources needed
to compile the Zaptel drivers, and potentially the Asterisk
implementation. I've just checked.

Its rather unfortunate, I'm sure I'm not the only one asking for
kernel driver source. However, as a point of interest, if you want to
port Plan9 to RPi, you can now do so, the video drivers are open
source...

There is a git repo that I can get the details for you again, if
needed. The only reason I haven't downloaded this was the fact its
over 200MB, and I have a data limit of 2,000MB per fortnight. I have a
little extra data at the moment, I might hook it all back up again
tomorrow, and try downloading the git. Set it to download before I go
to sleep, wake up again about 5am, and see where I'm up to.

I'm not sure how helpful this is for you, at this present time. If I
can help out in any other way, let me know, I'll see what I can come
up with. To get URIs working with the RPi would solve next years radio
application, our redesign of the RTCM won't be ready by early October
next year.

Actually, I'm going to go hook the RPi back up to its monitor and
cabling (I have a VESA mount plate for it), and get it working on the
network again - as mentioned, I'll set it to download just before I
take my tablets tonight, and let it run in off peak, hopefully there
isn't too much HSPA traffic on my local cell.

If the git is downloaded by tomorrow morning, I'll have a crack at
those kernel sources, and see if I can get Zaptel working. If that
works, then Asterisk should fall into line after it. All being well.

Now if only the local electronics shop could get me the 5 pin DIN
plugs and sockets I've ordered so I can hook up my SRM9000 to my
URI...

Hope this helps, even if we both know it isn't much at this point. Let
me know if theres anything else I can do.

Shane.

On Sat, Oct 27, 2012 at 1:16 PM, Ramesh Dhami (VA3UV) <Ramesh at va3uv.com> wrote:
> Hi Shane!
>
> Having got a few Raspberry Pi's going with my FREE STAR* project
> (www.freestar.us), I thought I'd give app_rpt a try.... I am also using the
> Raspbian "Wheezy" distro.
>
> How did you get the 'kernel-dev' package installed?
>
> I have tried a few different methods...
>
> apt-get install make gcc linux-headers-`uname -r`
>
> apt-get install raspberrypi-kernel-devel
>
> apt-get install linux-kernel-devel (-dev as well)
>
>
> And no joy!!!
>
> Do tell....
>
> Cheers!
>
> Ramesh.
>
>
>
>
>
>
>
>
> On 12/10/2012 2:16 AM, Shane Morris wrote:
>>
>> Hello all,
>>
>> I am using Raspbian on the RaspberryPi, which is a "wheezy" image,
>> upgraded to the latest kernels, using an aptitude copy of dahdi.
>>
>> I SVN checked out 1.4.23-pre of Asterisk as per the link on the Drupal
>> site, and have been mulling over the various issues as they popped up
>> during compilation.
>>
>> Where I've hit a brick wall is the "usb.h" file needed by
>> chan_simpleusb.c. I've had a poke around the guts of my Raspbian
>> install and tried a few files from the headers src package, but
>> nothing seems to work.
>>
>> I've also installed libusb2-dev from aptitude, again, to no avail in
>> terms of placing a "usb.h" file into the /usr/local/include/ folder.
>>
>> So, my question is this: while I can find plenty of references to
>> "usb.h" in the source files on the various repos on the net, I'm
>> unable to find a copy of the actual "usb.h" file - if someone could
>> shed some light on where I could potentially wget this file from
>> straight into my include folder, that would be great.
>>
>> As for my application, I'm using a RaspberryPi for the fact its very
>> low powered, and since I'll be using a 10Ahr Lithium solar/
>> performance car battery (started off as solar cells, were adapted to
>> performance cars like the Subaru WRX) and a solar panel/ controller, I
>> can gain autonomy over a weekend operating period. In short, I don't
>> want to drag a generator to the remote base to top off the batteries
>> if I can help it.
>>
>> The URI will be hooked to the Pi on one end, and a Simoco SRM9005 on
>> the other end, through a set of custom cables I'm (slowly) soldering
>> up. I did some more work on them today in terms of the DB25 to URIx
>> cable (which will go to a 5 pin DIN socket, then 5 pin DIN plug to
>> DB15 on the Simoco).
>>
>> On the client end I'll be using IAXRpt on my Macbook Air, which has
>> OSX 10.7 and the latest, sound enabled, WiNE package, along with
>> Winebottler wrapper program to make it nice and GUI like for me - not
>> that I'm afraid of a command line, I just like some things to be
>> simple, and sometimes our PEKAC troubleshooting has to be done with
>> non-experienced personnel, who would faint at the sight of a CLI.
>>
>> I've also got a Linksys SPA942 I want to try in terms of VOX
>> activation, but thats a secondary concern now I've got IAXRpt working
>> successfully on my Mac.
>>
>> Of course, success (under test conditions) will be I press "Ctrl" on
>> the Mac, and I hear my voice come out the SRM9025 head, and vice
>> versa, PTT the SRM9025 head and hear it come out the laptop. This will
>> be interesting, as the MBA doesn't have a microphone port, only a
>> built-in mic, and the Bluetooth stereo input device I bought at Aldi
>> didn't work... I also want a DJs "stick" headphone, as my role in
>> these weekend expeditions is PEKAC and general support, as well as
>> some operation - apparently I have a good, strong radio voice.
>>
>> Ok, enough rambling, as you can see, I'm using the various properties
>> of the systems to gain advantage over say a vanilla Limey Linux
>> install on an Atom. Plus I like ARM. I like a challenge, and if I were
>> to get this working, I'm sure my friend Andrew will be able to use my
>> Raspbian image on his Pis to make further remote bases for next years
>> expedition at Marramarra National Park. He has more Pis and Simocos
>> than me...
>>
>> Thanks in advance for any help you guys can give - I'll be interested
>> to hear your responses.
>> _______________________________________________
>> App_rpt-users mailing list
>> App_rpt-users at ohnosec.org
>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>>
>
> _______________________________________________
> App_rpt-users mailing list
> App_rpt-users at ohnosec.org
> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users



More information about the App_rpt-users mailing list