[App_rpt-users] Using SVN copy of Asterisk on RaspberryPi (and "usb.h")

Shane Morris edgecomberts at gmail.com
Sat Oct 27 12:54:16 EDT 2012


Excellent - tell me how you go with Win8, I'm interested in running it
in a VM =P

If you get Arch working, also let me know, I'm casting suspicion at
everything at the moment. While the SD card reformats fine, I haven't
actually tried it. For a brand new Class 10, it'd better work...!

By the way, you may find this interesting for Arch:

http://elinux.org/RPi_Kernel_Compilation

Hopefully it works a little better than Raspbian...

Enjoy!

On Sun, Oct 28, 2012 at 3:50 AM, Ramesh Dhami, VA3UV/M <ramesh at va3uv.com> wrote:
> On my way home - I have a W8 install to do this aft, so while that is happening.  I'll try the new distro on my Pi.
>
> Sent on the TELUS Mobility network with BlackBerry
>
> -----Original Message-----
> From: Shane Morris <edgecomberts at gmail.com>
> Date: Sun, 28 Oct 2012 03:29:27
> To: <ramesh at va3uv.com>
> Cc: app_rpt-users<app_rpt-users at ohnosec.org>
> Subject: Re: [App_rpt-users] Using SVN copy of Asterisk on RaspberryPi (and "usb.h")
>
> Ramesh, that image I just downloaded doesn't work. Unsure as to why,
> except it isn't the SD card at fault, so it must be the image. The
> computer isn't able to read the card once its imaged, ejected and
> reinserted.
>
> On Sun, Oct 28, 2012 at 1:49 AM, Shane Morris <edgecomberts at gmail.com> wrote:
>> Very good. Lets download, and dump to SD card =D
>>
>> On Sun, Oct 28, 2012 at 1:47 AM, Ramesh Dhami, VA3UV/M <ramesh at va3uv.com> wrote:
>>> Yep, I blv that it uses dpkg.
>>>
>>> Sent on the TELUS Mobility network with BlackBerry
>>>
>>> -----Original Message-----
>>> From: Shane Morris <edgecomberts at gmail.com>
>>> Date: Sun, 28 Oct 2012 01:38:46
>>> To: <ramesh at va3uv.com>
>>> Cc: app_rpt-users<app_rpt-users at ohnosec.org>
>>> Subject: Re: [App_rpt-users] Using SVN copy of Asterisk on RaspberryPi (and "usb.h")
>>>
>>> Certainly, I was thinking of doing a "dd" dump of my 8GB microSD card.
>>> And I think this would be invaluable to the community. Please, take it
>>> and modify it too!
>>>
>>> Alright, I'll download Arch before I go to sleep again - for my
>>> edification, Arch uses "dpkg" as the package manager, am I correct?
>>>
>>> On Sun, Oct 28, 2012 at 1:36 AM, Ramesh Dhami, VA3UV/M <ramesh at va3uv.com> wrote:
>>>> That's what it says on the RPi site, which makes me want to try it :)
>>>>
>>>> If we get this working folks, I'll put an image up on my site - but one step at a time....
>>>>
>>>> R.
>>>>
>>>> Sent on the TELUS Mobility network with BlackBerry
>>>>
>>>> -----Original Message-----
>>>> From: Shane Morris <edgecomberts at gmail.com>
>>>> Date: Sun, 28 Oct 2012 01:34:44
>>>> To: <ramesh at va3uv.com>
>>>> Cc: app_rpt-users<app_rpt-users at ohnosec.org>
>>>> Subject: Re: [App_rpt-users] Using SVN copy of Asterisk on RaspberryPi (and "usb.h")
>>>>
>>>> I like that quote: "not recommended for beginners" ^.~
>>>>
>>>> On Sun, Oct 28, 2012 at 1:31 AM, Ramesh Dhami, VA3UV/M <ramesh at va3uv.com> wrote:
>>>>> Google "Raspberry Pi Downloads"
>>>>>
>>>>> I think it is at the bottom of the list of downloads "not recommended for beginners"
>>>>>
>>>>> R.
>>>>>
>>>>> Sent on the TELUS Mobility network with BlackBerry
>>>>>
>>>>> -----Original Message-----
>>>>> From: Shane Morris <edgecomberts at gmail.com>
>>>>> Date: Sun, 28 Oct 2012 01:24:58
>>>>> To: <ramesh at va3uv.com>
>>>>> Cc: app_rpt-users<app_rpt-users at ohnosec.org>
>>>>> Subject: Re: [App_rpt-users] Using SVN copy of Asterisk on RaspberryPi (and "usb.h")
>>>>>
>>>>> Ah, yup. As long as it has some kind of standard kernel that you can
>>>>> get the source to, I think we'll be out of trouble. If you're able to
>>>>> at some point (perhaps when not mobile) could you give me a link to
>>>>> the distros webpage, so I can take a look?
>>>>>
>>>>> Many thanks!
>>>>>
>>>>> Shane.
>>>>>
>>>>> On Sun, Oct 28, 2012 at 1:22 AM, Ramesh Dhami, VA3UV/M <ramesh at va3uv.com> wrote:
>>>>>> Hi Shane:
>>>>>>
>>>>>> I am mobile atm.
>>>>>>
>>>>>> I was going to try the ARM distro - that may offer some advantages over the Raspbian distro.
>>>>>>
>>>>>> R.
>>>>>>
>>>>>> Sent on the TELUS Mobility network with BlackBerry
>>>>>>
>>>>>> -----Original Message-----
>>>>>> From: Shane Morris <edgecomberts at gmail.com>
>>>>>> Sender: app_rpt-users-bounces at ohnosec.org
>>>>>> Date: Sun, 28 Oct 2012 01:03:11
>>>>>> To: app_rpt mailing list<app_rpt-users at ohnosec.org>
>>>>>> Subject: Re: [App_rpt-users] Using SVN copy of Asterisk on RaspberryPi (and
>>>>>>         "usb.h")
>>>>>>
>>>>>> Ok, Ramesh, and list, an update:
>>>>>>
>>>>>> This makes sense. I expect this to change in the not too distant
>>>>>> future, but for now, we hold on tight.
>>>>>>
>>>>>> The fact those video drivers were made open source is actually *very*
>>>>>> important. Since RPi doesn't use a standard way of booting (read:
>>>>>> GRUB) due to the peculiarities of the way the system boots, related to
>>>>>> the GPU, the actual kernel cannot be built in a "standard" way, ie,
>>>>>> Debian process. So anything you read on the net, regards building a
>>>>>> kernel may or may not work, YMMV, but I'm willing to bet a nickel to a
>>>>>> million it won't work.
>>>>>>
>>>>>> This is very similar to the PS2 Linux I used to use, and I'm not sure
>>>>>> why I haven't seen it before now. But, hindsight is a wonderful thing,
>>>>>> right? =P
>>>>>>
>>>>>> So, the shakedown from this is that, potentially, there will be a
>>>>>> release of a "standard" bootloader, and a "standard" kernel. Which
>>>>>> means the custom kernel (3.2.27+) which sure as heck don't have a
>>>>>> aptitude package, and probably never will, doesn't have to be used any
>>>>>> more, and a standard kernel might be able to be used in its place. The
>>>>>> flow on effect? We can now download the kernel sources, via a command
>>>>>> like "sudo apt-get install linux-sources-3.2" for example.
>>>>>>
>>>>>> A timeframe for this "standard" Raspbian release is unknown at this
>>>>>> stage, the GPU/ bootloader source was only released four days ago...!
>>>>>> But Ramesh, even though you and I may have to download a new version
>>>>>> of Raspbian, and then the SVN of Allstar, and all the aptitude
>>>>>> packages *again*, there may be a light at the end of the tunnel...
>>>>>>
>>>>>> On Sun, Oct 28, 2012 at 12:01 AM, Shane Morris <edgecomberts at gmail.com> wrote:
>>>>>>> Sorry all, didn't click "Reply to all" - oops!
>>>>>>>
>>>>>>>
>>>>>>> ---------- Forwarded message ----------
>>>>>>> From: Shane Morris <edgecomberts at gmail.com>
>>>>>>> Date: Sat, Oct 27, 2012 at 11:59 PM
>>>>>>> Subject: Re: [App_rpt-users] Using SVN copy of Asterisk on RaspberryPi
>>>>>>> (and "usb.h")
>>>>>>> To: "Ramesh Dhami (VA3UV)" <Ramesh at va3uv.com>
>>>>>>>
>>>>>>>
>>>>>>> Hey Ramesh,
>>>>>>>
>>>>>>> I agree, no one seems to really care about the RPi at the moment -
>>>>>>> theres glory in open sourcing those video drivers I alluded to before,
>>>>>>> and getting Plan9 to work on it, and believe you me, I'd love to see
>>>>>>> that, but the thing is, right now, the blokes on the ground who don't
>>>>>>> have the software to do what they need are suffering.
>>>>>>>
>>>>>>> The other thing is, RPi forums are not coming to the party. Unsure as
>>>>>>> to why. I have noted that I'm using an older version of Asterisk and
>>>>>>> thats a deliberate thing - newer versions of Asterisk don't have
>>>>>>> support for app_rpt, as far as I'm aware. Possibly they see we're
>>>>>>> using such an old version, and wash their hands of us straight away
>>>>>>> due to compatibility issues...?
>>>>>>>
>>>>>>> I had a similar situation with FreeSWiTCH once, downloaded the trunk
>>>>>>> the night before they did a big update from 0.4 to 0.5 and of course,
>>>>>>> they'd changed the way the config files worked, totally. Went onto IRC
>>>>>>> to talk about it, they were really good about it, but they kind of
>>>>>>> said, "Gee, you must have downloaded the trunk at the wrong time..."
>>>>>>>
>>>>>>> Of course, I refuse to let my URI become an AU$180 paperweight.
>>>>>>>
>>>>>>> Practicality: there is no aptitude package for the kernel source. Its
>>>>>>> as simple as that. From 3.1.9 to 3.2.27+, not a cracker. They cite
>>>>>>> this is a fast moving target, and while I sympathise with them, this
>>>>>>> thing *is* moving, it leaves poor blokes like you and I out in the
>>>>>>> cold. And I bet we're not the only ones asking about the kernel
>>>>>>> source...! I've tried using "apt-cache search kernel-devel" and
>>>>>>> nothing. I'm considering adding mainline Debian repos to aptitude, and
>>>>>>> downloading the kernel source for Wheezy from there. I may have to
>>>>>>> then disable the mainline repos, I'd actually run into issues with the
>>>>>>> compilation of Asterisk (before realising app_rpt wasn't able to be
>>>>>>> selected) and the particular architecture - GSM codec won't compile
>>>>>>> for an ARMv6 target, must be generic ARM.
>>>>>>>
>>>>>>> That should, in theory, work. Since the package is source, and not a
>>>>>>> platform specific application, theres no case of it downloading an x86
>>>>>>> package, say, and trying to execute it. As for the hooks? Unsure,
>>>>>>> there would be a particular directory structure that it would create.
>>>>>>> But then theres a proviso: since its a "canned" package, will it
>>>>>>> actually work?
>>>>>>>
>>>>>>> I've actually installed tonezone2-dev from aptitude, and then was
>>>>>>> told, don't, it won't work. I must install the source version of
>>>>>>> tonezone included with Zaptel included with the SVN version of
>>>>>>> Allstar. I don't doubt why. They built it. Plus is the tonezone2 too
>>>>>>> new? Etc etc. I didn't really ask why, I think understand enough.To
>>>>>>> get myself into trouble, evidently.
>>>>>>>
>>>>>>> I cant sleep at the moment, and I'm not tired. Might grab a coffee,
>>>>>>> drag out the Macbook out to the dining room where my DJ rack with the
>>>>>>> equipment in it sits in the corner, and try this adding repo thing. I
>>>>>>> encourage you to try the same - if only so we can compare notes. I
>>>>>>> take it you're in Canada with a "VA" callsign? I was VK2FPGA before I
>>>>>>> let it lapse due to personal issues. I'm doing this for a community
>>>>>>> group at the moment who, at a particular part of the year, get a two
>>>>>>> week temporary licence, and use Simoco SRM9000s on UHF. If I can get
>>>>>>> this working, I might be able to give my mate this as part of his
>>>>>>> wedding present, although I'm sure his bride will question the
>>>>>>> applicability to her ^.^ Don't worry, they're getting a lovely photo
>>>>>>> frame that I'm going to encourage them to put a photo of their special
>>>>>>> day into.
>>>>>>>
>>>>>>> In any case, Ramesh, I hope this is a little food for thought for ya,
>>>>>>> I'm trying to think about ways around the problem. I mean, there has
>>>>>>> to be some way around it, its Linux for crying out loud! It *is* the
>>>>>>> hackers OS, after all...
>>>>>>>
>>>>>>> Hope this helps...!
>>>>>>>
>>>>>>> Shane.
>>>>>>>
>>>>>>> On Sat, Oct 27, 2012 at 11:27 PM, Ramesh Dhami (VA3UV) <Ramesh at va3uv.com> wrote:
>>>>>>>> Hi Shane;
>>>>>>>>
>>>>>>>> Seems like there is little interest in the PI at the moment!
>>>>>>>>
>>>>>>>> Here are the notes that Jim gave me to install Asterisk / app_rpt on my ALIX
>>>>>>>> board, running Centos.... of course the commands and packages will need to
>>>>>>>> be adjusted - but, may be this will help you:
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> # bear in mind, this applies to *this particular installation*... some
>>>>>>>> needed stuff
>>>>>>>> # was already installed.. if you want a completely inclusive list of all the
>>>>>>>> stuff done
>>>>>>>> # on a completely bear Centos install, look at the phase1.sh script in the
>>>>>>>> acid trunk SVN directory
>>>>>>>>
>>>>>>>> # update to latest kernel (since the 'kenrnel-devel' package will have to
>>>>>>>> match this version
>>>>>>>> yum -y update kernel
>>>>>>>>
>>>>>>>> # install all packages needed to support Zaptel/Asterisk
>>>>>>>> yum -y install zlib-devel kernel-devel alsa-lib-devel ncurses-devel
>>>>>>>> libusb-devel newt-devel openssl-devel curl-devel
>>>>>>>>
>>>>>>>> # install from SVN (per Allstarlink site)
>>>>>>>> cd /usr/src
>>>>>>>> rm -rf astsrc
>>>>>>>>
>>>>>>>>
>>>>>>>> mv trunk astsrc
>>>>>>>> cd astsrc
>>>>>>>> make upgrade-acid
>>>>>>>>
>>>>>>>> # install the initial default config files to make a SimpleUSB node
>>>>>>>> cd /usr/src/astsrc/configs
>>>>>>>> cp *.conf /etc/asterisk
>>>>>>>> cd simpleusb
>>>>>>>> cp *.conf /etc/asterisk
>>>>>>>>
>>>>>>>> # move the 'zaptel.conf' file to the right place
>>>>>>>> cd /etc/asterisk
>>>>>>>> mv zaptel.conf /etc
>>>>>>>>
>>>>>>>> # install the system (boot) startup files for Zaptel
>>>>>>>> cd /usr/src/astsrc/zaptel
>>>>>>>> make config
>>>>>>>>
>>>>>>>> # install the system (boot) startup files for Asterisk
>>>>>>>> cd /usr/src/astsrc/asterisk
>>>>>>>> make config
>>>>>>>>
>>>>>>>> # Start Zaptel manually this time
>>>>>>>> service zaptel start
>>>>>>>>
>>>>>>>> # Start Asterisk manually this time
>>>>>>>> service asterisk start
>>>>>>>>
>>>>>>>>
>>>>>>>> # now you have a running Asterisk/app_rpt system
>>>>>>>> # with a "default" SimpleUSB configuration
>>>>>>>> # this does *not*, however, install the Allstar Support
>>>>>>>> # scripts, like updatenodelist
>>>>>>>>
>>>>>>>>
>>>>>>>> =================================
>>>>>>>>
>>>>>>>> So far, I have installed:
>>>>>>>>
>>>>>>>> zlib1g-dev
>>>>>>>> alsa-utils
>>>>>>>> libncurses5-dev
>>>>>>>> libusb-dev
>>>>>>>> libnewt-dev
>>>>>>>>
>>>>>>>>
>>>>>>>> Jim's instructions say to install "kernel-devel" - we need to solve this
>>>>>>>> mystery.
>>>>>>>>
>>>>>>>>
>>>>>>>> How are you compiling the zaptel stuff?
>>>>>>>>
>>>>>>>>
>>>>>>>> Have you done a 'make upgrade-acid' in the /usr/src/astsrc folder? - were
>>>>>>>> you able to get that to work?
>>>>>>>>
>>>>>>>>
>>>>>>>> Cheers,
>>>>>>>>
>>>>>>>> Ramesh.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On 27/10/2012 4:33 AM, Shane Morris wrote:
>>>>>>>>>
>>>>>>>>> Hi all,
>>>>>>>>>
>>>>>>>>> Just as an update, I've cloned the git repo for RPi, and it has what
>>>>>>>>> should be the 3.2.27+ kernel source in it. Unfortunately for me, when
>>>>>>>>> I go to "make" Zaptel, it still tells me I don't have the required
>>>>>>>>> kernel sources. Now, I have put the symbolic links in the /usr/src
>>>>>>>>> directory, still no dice.
>>>>>>>>>
>>>>>>>>> I have just checked the github.com site, and lo and behold, 3.2.27+ -
>>>>>>>>> hmmm, rather interesting.
>>>>>>>>>
>>>>>>>>> Is there any other processes or files that I may still require to try
>>>>>>>>> to get the thing to realise I've just downloaded the kernel source?
>>>>>>>>>
>>>>>>>>> Many thanks for your help...!
>>>>>>>>>
>>>>>>>>> Shane.
>>>>>>>>>
>>>>>>>>> On Sat, Oct 27, 2012 at 1:43 PM, Shane Morris <edgecomberts at gmail.com>
>>>>>>>>> wrote:
>>>>>>>>>>
>>>>>>>>>> Hi mate!
>>>>>>>>>>
>>>>>>>>>> I've had Real Life (TM) intervene in the meantime since my last email,
>>>>>>>>>> and I've not been able to invest any time in the project.
>>>>>>>>>>
>>>>>>>>>> Additionally, theres not been any responses to my post on the RPi
>>>>>>>>>> forums regards the information I need to get the kernel sources needed
>>>>>>>>>> to compile the Zaptel drivers, and potentially the Asterisk
>>>>>>>>>> implementation. I've just checked.
>>>>>>>>>>
>>>>>>>>>> Its rather unfortunate, I'm sure I'm not the only one asking for
>>>>>>>>>> kernel driver source. However, as a point of interest, if you want to
>>>>>>>>>> port Plan9 to RPi, you can now do so, the video drivers are open
>>>>>>>>>> source...
>>>>>>>>>>
>>>>>>>>>> There is a git repo that I can get the details for you again, if
>>>>>>>>>> needed. The only reason I haven't downloaded this was the fact its
>>>>>>>>>> over 200MB, and I have a data limit of 2,000MB per fortnight. I have a
>>>>>>>>>> little extra data at the moment, I might hook it all back up again
>>>>>>>>>> tomorrow, and try downloading the git. Set it to download before I go
>>>>>>>>>> to sleep, wake up again about 5am, and see where I'm up to.
>>>>>>>>>>
>>>>>>>>>> I'm not sure how helpful this is for you, at this present time. If I
>>>>>>>>>> can help out in any other way, let me know, I'll see what I can come
>>>>>>>>>> up with. To get URIs working with the RPi would solve next years radio
>>>>>>>>>> application, our redesign of the RTCM won't be ready by early October
>>>>>>>>>> next year.
>>>>>>>>>>
>>>>>>>>>> Actually, I'm going to go hook the RPi back up to its monitor and
>>>>>>>>>> cabling (I have a VESA mount plate for it), and get it working on the
>>>>>>>>>> network again - as mentioned, I'll set it to download just before I
>>>>>>>>>> take my tablets tonight, and let it run in off peak, hopefully there
>>>>>>>>>> isn't too much HSPA traffic on my local cell.
>>>>>>>>>>
>>>>>>>>>> If the git is downloaded by tomorrow morning, I'll have a crack at
>>>>>>>>>> those kernel sources, and see if I can get Zaptel working. If that
>>>>>>>>>> works, then Asterisk should fall into line after it. All being well.
>>>>>>>>>>
>>>>>>>>>> Now if only the local electronics shop could get me the 5 pin DIN
>>>>>>>>>> plugs and sockets I've ordered so I can hook up my SRM9000 to my
>>>>>>>>>> URI...
>>>>>>>>>>
>>>>>>>>>> Hope this helps, even if we both know it isn't much at this point. Let
>>>>>>>>>> me know if theres anything else I can do.
>>>>>>>>>>
>>>>>>>>>> Shane.
>>>>>>>>>>
>>>>>>>>>> On Sat, Oct 27, 2012 at 1:16 PM, Ramesh Dhami (VA3UV) <Ramesh at va3uv.com>
>>>>>>>>>> wrote:
>>>>>>>>>>>
>>>>>>>>>>> Hi Shane!
>>>>>>>>>>>
>>>>>>>>>>> Having got a few Raspberry Pi's going with my FREE STAR* project
>>>>>>>>>>> (www.freestar.us), I thought I'd give app_rpt a try.... I am also using
>>>>>>>>>>> the
>>>>>>>>>>> Raspbian "Wheezy" distro.
>>>>>>>>>>>
>>>>>>>>>>> How did you get the 'kernel-dev' package installed?
>>>>>>>>>>>
>>>>>>>>>>> I have tried a few different methods...
>>>>>>>>>>>
>>>>>>>>>>> apt-get install make gcc linux-headers-`uname -r`
>>>>>>>>>>>
>>>>>>>>>>> apt-get install raspberrypi-kernel-devel
>>>>>>>>>>>
>>>>>>>>>>> apt-get install linux-kernel-devel (-dev as well)
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> And no joy!!!
>>>>>>>>>>>
>>>>>>>>>>> Do tell....
>>>>>>>>>>>
>>>>>>>>>>> Cheers!
>>>>>>>>>>>
>>>>>>>>>>> Ramesh.
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> On 12/10/2012 2:16 AM, Shane Morris wrote:
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Hello all,
>>>>>>>>>>>>
>>>>>>>>>>>> I am using Raspbian on the RaspberryPi, which is a "wheezy" image,
>>>>>>>>>>>> upgraded to the latest kernels, using an aptitude copy of dahdi.
>>>>>>>>>>>>
>>>>>>>>>>>> I SVN checked out 1.4.23-pre of Asterisk as per the link on the Drupal
>>>>>>>>>>>> site, and have been mulling over the various issues as they popped up
>>>>>>>>>>>> during compilation.
>>>>>>>>>>>>
>>>>>>>>>>>> Where I've hit a brick wall is the "usb.h" file needed by
>>>>>>>>>>>> chan_simpleusb.c. I've had a poke around the guts of my Raspbian
>>>>>>>>>>>> install and tried a few files from the headers src package, but
>>>>>>>>>>>> nothing seems to work.
>>>>>>>>>>>>
>>>>>>>>>>>> I've also installed libusb2-dev from aptitude, again, to no avail in
>>>>>>>>>>>> terms of placing a "usb.h" file into the /usr/local/include/ folder.
>>>>>>>>>>>>
>>>>>>>>>>>> So, my question is this: while I can find plenty of references to
>>>>>>>>>>>> "usb.h" in the source files on the various repos on the net, I'm
>>>>>>>>>>>> unable to find a copy of the actual "usb.h" file - if someone could
>>>>>>>>>>>> shed some light on where I could potentially wget this file from
>>>>>>>>>>>> straight into my include folder, that would be great.
>>>>>>>>>>>>
>>>>>>>>>>>> As for my application, I'm using a RaspberryPi for the fact its very
>>>>>>>>>>>> low powered, and since I'll be using a 10Ahr Lithium solar/
>>>>>>>>>>>> performance car battery (started off as solar cells, were adapted to
>>>>>>>>>>>> performance cars like the Subaru WRX) and a solar panel/ controller, I
>>>>>>>>>>>> can gain autonomy over a weekend operating period. In short, I don't
>>>>>>>>>>>> want to drag a generator to the remote base to top off the batteries
>>>>>>>>>>>> if I can help it.
>>>>>>>>>>>>
>>>>>>>>>>>> The URI will be hooked to the Pi on one end, and a Simoco SRM9005 on
>>>>>>>>>>>> the other end, through a set of custom cables I'm (slowly) soldering
>>>>>>>>>>>> up. I did some more work on them today in terms of the DB25 to URIx
>>>>>>>>>>>> cable (which will go to a 5 pin DIN socket, then 5 pin DIN plug to
>>>>>>>>>>>> DB15 on the Simoco).
>>>>>>>>>>>>
>>>>>>>>>>>> On the client end I'll be using IAXRpt on my Macbook Air, which has
>>>>>>>>>>>> OSX 10.7 and the latest, sound enabled, WiNE package, along with
>>>>>>>>>>>> Winebottler wrapper program to make it nice and GUI like for me - not
>>>>>>>>>>>> that I'm afraid of a command line, I just like some things to be
>>>>>>>>>>>> simple, and sometimes our PEKAC troubleshooting has to be done with
>>>>>>>>>>>> non-experienced personnel, who would faint at the sight of a CLI.
>>>>>>>>>>>>
>>>>>>>>>>>> I've also got a Linksys SPA942 I want to try in terms of VOX
>>>>>>>>>>>> activation, but thats a secondary concern now I've got IAXRpt working
>>>>>>>>>>>> successfully on my Mac.
>>>>>>>>>>>>
>>>>>>>>>>>> Of course, success (under test conditions) will be I press "Ctrl" on
>>>>>>>>>>>> the Mac, and I hear my voice come out the SRM9025 head, and vice
>>>>>>>>>>>> versa, PTT the SRM9025 head and hear it come out the laptop. This will
>>>>>>>>>>>> be interesting, as the MBA doesn't have a microphone port, only a
>>>>>>>>>>>> built-in mic, and the Bluetooth stereo input device I bought at Aldi
>>>>>>>>>>>> didn't work... I also want a DJs "stick" headphone, as my role in
>>>>>>>>>>>> these weekend expeditions is PEKAC and general support, as well as
>>>>>>>>>>>> some operation - apparently I have a good, strong radio voice.
>>>>>>>>>>>>
>>>>>>>>>>>> Ok, enough rambling, as you can see, I'm using the various properties
>>>>>>>>>>>> of the systems to gain advantage over say a vanilla Limey Linux
>>>>>>>>>>>> install on an Atom. Plus I like ARM. I like a challenge, and if I were
>>>>>>>>>>>> to get this working, I'm sure my friend Andrew will be able to use my
>>>>>>>>>>>> Raspbian image on his Pis to make further remote bases for next years
>>>>>>>>>>>> expedition at Marramarra National Park. He has more Pis and Simocos
>>>>>>>>>>>> than me...
>>>>>>>>>>>>
>>>>>>>>>>>> Thanks in advance for any help you guys can give - I'll be interested
>>>>>>>>>>>> to hear your responses.
>>>>>>>>>>>> _______________________________________________
>>>>>>>>>>>> App_rpt-users mailing list
>>>>>>>>>>>> App_rpt-users at ohnosec.org
>>>>>>>>>>>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> _______________________________________________
>>>>>>>>>>> App_rpt-users mailing list
>>>>>>>>>>> App_rpt-users at ohnosec.org
>>>>>>>>>>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>>>>>>>>
>>>>>>>>
>>>>>> _______________________________________________
>>>>>> App_rpt-users mailing list
>>>>>> App_rpt-users at ohnosec.org
>>>>>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users



More information about the App_rpt-users mailing list