[App_rpt-users] Using SVN copy of Asterisk on RaspberryPi (and "usb.h")

Shane Morris edgecomberts at gmail.com
Sun Oct 28 01:51:59 EDT 2012


Hi Ramesh, and rest of list,

First up, for those interested in this project, here is a link:

http://www.raspberrypi.org/archives/2221

This'll give you the background on what I'll say next. I have my
people looking at this, response isn't expected for a couple of hours,
the bloke is gardening. My skills in the garden extend to watering my
parsley and chives. =)

Basically, the intent of that blog post is to say that the VideoCore
drivers on the RPi have been open sourced. While in and of itself is
not really applicable to this project, the flow on effect is. From
what I understand, the GPU handles the boot process, and at the
moment, the canned binaries point to a certain location in memory, and
the ARM picks up from there with a custom kernel.

This is our problem.

With a custom kernel, then the kernel sources are not mainlined, so
aptitude isn't of any help. I tried the git download, it too didn't
work. I almost (!) got Zaptel to compile on Arch (see last email) but
it too is now whining it can't find kernel sources, which don't make
any sense to me.

Now with the video drivers being open sourced, documentation about the
boot process of the GPU will become available, thus no longer
necessitating a custom kernel. Flow on? We can use a standard kernel
package that'll allow us to (hopefully!) compile Zaptel quite fine.

Although my time frame for this is early October next year, and I know
that the distros with the new boot code and standard kernels will come
out before that, I'm kind of a bit impatient...! This is big news, of
course. I want this to work, and I want to give a copy to my friend
who works with me on the radios for Sydney Pathfinders, and all you
good souls out there putting up with my inane comments.

I will be following raspberrypi.org closely over the next few weeks
regards the distros that'll use this new bootloader and kernel code.
Exciting times indeed!

Thanks everyone!

Shane.

On Sun, Oct 28, 2012 at 1:03 PM, Shane Morris <edgecomberts at gmail.com> wrote:
> Ramesh,
>
> I started going from the other way around, compile, let it fall over
> and then make a dependancy. And it worked, somewhat.
>
> I actually had Zaptel compiling and not complaining about those kernel
> sources! But only once! =(
>
> The second run, after I installed libnewt, it started complaining
> again. I'm just wondering who wants a drink of my good scotch to just
> make it work?! ^.^
>
> Seriously, theres some kind of issue here, if its going to compile
> once, then it KNOWS those sources are there. Is it related to
> installing programs? As silly as that sounds - I know this isn't
> Windows...! =O
>
> I am considering starting right from the top, reflashing the SD card,
> and making the dependancies first, then letting Zaptel have a go at
> it. Took about 150 seconds for a write of the SD card when I started
> using "rdisk1."
>
> If anything Ramesh, this is why they ain't paying us the big
> dollars... ^.~ And yes, they have a sense of humour with "pacman" - a
> bloody good game! Back when computers were computers, men were men,
> and the bikini babes wore less. =P
>
> Good luck from this side of the ocean.
>
> Shane.
>
> On Sun, Oct 28, 2012 at 12:36 PM, Ramesh Dhami (VA3UV) <Ramesh at va3uv.com> wrote:
>> Update...
>>
>> I do have this folder:
>>
>> /usr/lib/modules/3.2.27-13-ARCH+
>>
>> Contents:
>>
>> lrwxrwxrwx 1 root root     34 Oct 21 03:20 build ->
>> ../../../src/linux-3.2.27-13-ARCH+
>> lrwxrwxrwx 1 root root     35 Oct 21 03:20 extramodules ->
>> ../extramodules-3.2.27--raspberrypi
>> drwxr-xr-x 9 root root   4096 Oct 21 03:19 kernel
>> -rw-r--r-- 1 root root 290711 Oct 27 23:03 modules.alias
>> -rw-r--r-- 1 root root 303750 Oct 27 23:03 modules.alias.bin
>> -rw-r--r-- 1 root root   3606 Oct 21 03:19 modules.builtin
>> -rw-r--r-- 1 root root   4666 Oct 27 23:03 modules.builtin.bin
>> -rw-r--r-- 1 root root 101681 Oct 27 23:03 modules.dep
>> -rw-r--r-- 1 root root 149435 Oct 27 23:03 modules.dep.bin
>> -rw-r--r-- 1 root root    244 Oct 27 23:03 modules.devname
>> -rw-r--r-- 1 root root  43539 Oct 21 03:19 modules.order
>> -rw-r--r-- 1 root root    131 Oct 27 23:03 modules.softdep
>> -rw-r--r-- 1 root root  99446 Oct 27 23:03 modules.symbols
>> -rw-r--r-- 1 root root 126722 Oct 27 23:03 modules.symbols.bin
>>
>>
>> So... am I close.... me seems to think so.... what am I missing?
>>
>> Time to give it a break for today!
>>
>> R.
>>
>>
>>
>>
>> On 27/10/2012 9:27 PM, Ramesh Dhami (VA3UV) wrote:
>>>
>>> On 27/10/2012 6:17 PM, Shane Morris wrote:
>>>>
>>>> Ok, my little lesson, on Mac OS X, dont use "/dev/disk1s1" for the
>>>> "of=" option, use "/dev/rdisk1" =)
>>>>
>>>> Now to try this out...!
>>>>
>>>
>>> <-- Hi Shane and all;
>>>
>>> Enough playing around for today, here is what I have done (and really
>>> haven't got any further with the ARCH Linux distro) - regardless, for
>>> the sake of documenting what I have done - here goes:
>>>
>>> Installed the ARCH Linux distro...
>>>
>>> pacman - is the package manager (wasn;t this a video game that we played
>>> with back in the 70's or so???).
>>>
>>> So to update everything:
>>>
>>> pacman -Syu
>>>
>>> then using pacman -S added the following:
>>>
>>> libnewt
>>> alsa-lib
>>> ncurses
>>> libnewt
>>> openssl
>>> curl
>>> zlib
>>> make
>>> gcc
>>> linux
>>> linux-headers
>>>
>>>
>>> As I said, no further ahead - I still get errors complaining that the
>>> kernel sources are not available!
>>>
>>>
>>> I wonder, is there a way to cross compile on another platform and then
>>> just run the binaries on the Pi ????
>>>
>>>
>>> R.
>>>
>>> _______________________________________________
>>> App_rpt-users mailing list
>>> App_rpt-users at ohnosec.org
>>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>>
>>
>> _______________________________________________
>> App_rpt-users mailing list
>> App_rpt-users at ohnosec.org
>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users



More information about the App_rpt-users mailing list