[App_rpt-users] D2700MUD and Limey...

Randy Neals randy at neals.ca
Sun Oct 28 23:47:51 EDT 2012


Ok, next problem...

Limey works, and boots. Now working through the set up scripts.

I'm following the instructions in the support section...
https://allstarlink.org/support.html

In order to configure your server to allow the Portal to generate
configuration files for the server, you first must download a local
configuration shell script and execute it. Please do the following:

cd /tmp
curl -L https://allstarlink.org/config/portalconfig.sh -o foo.sh
sh foo.sh ; rm foo.sh

The Curl part works and downloads a file. I can see the file foo.sh in the
directory.
When I run the script... the second line.. I get an error

" foo.sh line 15 function not found"

I searched through the list to see if others have saw this, there are 3
posts relating to foo.sh, but no follow-ups/answers..

What to do now?

Randy


On Sun, Oct 28, 2012 at 7:37 PM, Randy Neals <randy at neals.ca> wrote:

> Problem solved! onward we go.
> Jim politely reminded me to use the correct limey image on the D2700MUD
> Mobo. :)
> (I was using he standard i686 image)
>
> For the benefit of others that are using teh D2700MUD Mobo here is the
> link.
> http://stats.allstarlink.org/limeylinux/downloads/cfimg-D2700MUD.tar.gz
>
> Ok, I'm now booted and going through the first-time config.
>
>
> Randy/W3RWN
>
>
> On Sun, Oct 28, 2012 at 6:57 PM, Randy Neals <randy at neals.ca> wrote:
>
>> Hi folks,
>>
>> I received my parts this week and started building a node.
>> The parts I've acquired:
>> Intel D2700MUD Motherboard:
>> http://www.intel.com/cd/products/services/emea/eng/motherboards/desktop/D2700MUD/overview/487677.htm
>> ARK CS-Ci02 mini-itx case:
>> http://www.arktechinc.net/server-case/cs-ci02.html
>> Crucial 2GB SODIMM DDR3PC3 memory
>>
>> The D2700 Motherboard has an embedded USB storage header on the
>> motherboard.
>> Rather than using a compact flash drive, I acquired some SanDisk 512MB
>> Embedded USB Flash storage devices. (Found on eBay)
>> Here's some documentation on that
>> http://media.digikey.com/pdf/Data%20Sheets/M-Systems%20Inc%20PDFs/uSSD_5000_Manual_03.pdf
>>
>> I downloaded the Limey Linux image, and used Physdiskwrite on my windows
>> pc to write the image to the USB Flash drive.
>> Inserted the USB flash drive on the header, and gave it a rip.
>>
>> You'll find pictures of the case, mobo and flash drive here.
>> http://www.neals.ca/w3rwn
>>
>> Ok, so it boots... loads kernel, makes a ram disk, and runs through a
>> long list of boot up things.
>> It mounts the root filesystem then seems to die.
>>
>> VFS: Mounted root (ext2 filesystem) readonly on device 1:0
>> Freeing unused kernel memory: 292k freed
>> EXT2-fs warning: checktime reached, running e2fsck reccomended
>>
>> There is no command prompt, so not sure what I should be doing next?  Doh!
>>
>> I'm going to try a different boot image for linux, and check out the
>> hardware independently.
>>
>> Thanks,
>> Randy
>> W3RWN (ex KI6TWT)
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20121028/cb58fb78/attachment.html>


More information about the App_rpt-users mailing list