[App_rpt-users] G707 Remote Base Locking Up on URI

K&R Yoksh yokshs at gmail.com
Tue Jun 11 21:42:15 EDT 2013


Hello Monty,
While not specific to the remote operation, I see one thing that might make 
app_rpt lose it's mind.

The rxchannel parameter is very picky about syntax, especially the upper and 
lower case letters. The correct format is:

rxchannel=SimpleUSB/usb1010

Another thing I've learned is to never (NEVER) have usbradio.conf and 
simpleusb.conf exist in /etc/asterisk at the same time. This will
confuse app_rpt at the least, or crash it altogether.

73,

Kyle Yoksh
K0KN
Olathe, KS
Allstar 2210-2219
--- Original Message ---Hello Everyone,

I have tried two Kenwood G707s with three of Jim's URI Adapter cards and
two URIs on two different computers.  I am able to get three or four
commands (freq, pl tone, etc) then I will get Allison saying "Invalid
Frequency" and the CLI shows:

"WARNING[7925]: app_rpt.c:13876 serial_remote_io: -99999 Serial device not
responding on node 1010"

The radio will not steer or accept commands anymore until I power cycle the
707.  The after power cycle three or four commands and will not steer
again.  I have tried the same computer with a VHF Syntor with an xcat and
will accept every command without issue.  Also one of my 707s now lives on
a Quad PCI card and steers with every command without issue.  Has anyone
else seen this or know the remedy?  Below is my rpt.conf with the URI:

[1010]
archivedir=/etc/asterisk/qso
rxchannel = simpleusb/usb1010
duplex=0
ioport = /dev/ttyS0
remote = kenwood
authlevel = 1
memory=memory
remote_inact_timeout=5400
remote_timeout=5400
functions=remote-functions
phone_functions=remote-functions
link_functions=remote-functions 




More information about the App_rpt-users mailing list