[App_rpt-users] Courtesy Tones.....

Jon Rorke jrorke at cogeco.ca
Mon Jun 24 13:40:23 EDT 2013


Since this is a half duplex radio, make sure you have duplex=1 in 
rpt.conf _and_ in usbradio.conf you have duplex = 0.

If usbradio has duplex = 1 then it thinks you have a full duplex radio.
You need to tell usbradio it is half duplex.


By default app-Rpt defaults to full duplex settings in both usbradio and 
in rpt conf.
Actually when duplex = X is not stated in then it is automatically in 
full duplex mode in rpt conf.

Jon VA3RQ

On 6/24/2013 1:10 PM, James Hill wrote:
> Hi Mike,
>
> I have a Simplex node, Hardware is Dell Latitude D600, connected to 
> WLAN at 150mpbs. External ADSL is good, 15580mbps download speed. 
> Running Top indicates:
>
> top - 17:55:39 up 5 min,  2 users,  load average: 0.14, 0.22, 0.12
> Tasks:  71 total,   2 running,  69 sleeping,   0 stopped,   0 zombie
> Cpu(s):  2.3%us,  0.3%sy,  0.0%ni, 97.3%id,  0.0%wa,  0.0%hi, 0.0%si,  
> 0.0%st
> Mem:    514596k total,   216224k used,   298372k free,    15360k buffers
> Swap:  1020116k total,        0k used,  1020116k free,   139908k cached
>
>   PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+ COMMAND
>  2466 root      15   0 39152  18m 5584 S  2.7  3.6   0:10.81 asterisk
>  2809 root      15   0  2312 1008  812 R  0.3  0.2   0:00.01 top
>
> Interface is modified CM108 USB device.
>
> The problem I have, is when unconnected to any node. When connected, 
> all is good - When station TXing on the link drops their TX, courtesy 
> pip. All good.
>
> The Issue is obviously something local, as whenever a signal is RXed 
> locally, the box responds with a courtesy pip and a CWID and then 
> drops carrier. But then proceeds to key up numerous times (anywhere 
> between 6 & 14 at the last count), each key up giving a pip and then 
> dropping carrier. If I go into rpt.conf and set unlinkedct=0, it will 
> still key up multiple times - but no tone.
>
> If I set duplex=0, the problem goes away (but I get no courtesy tones 
> - but I still get "function complete" etc ok).
>
> Something is looping somewhere.... it's just a case of trying to find it!
>
> rpt.conf is pasted below!
>
> Cheers,
>
> James
>
> [29681]                                 ; Change this to your assigned 
> node number
>
> rxchannel=Radio/usb29681
> duplex=1
> erxgain=-6
> etxgain=-6
> ;controlstates=controlstates
> scheduler=schedule29681
> morse=morse29681
> macro=macro29681
> functions=functions29681
> phone_functions=functions29681
> link_functions=functions29681
> telemetry=telemetry
> wait_times=wait-times
> context =  radio
> callerid = "Repeater" <0000000000>
> idrecording = |iG0FHM F
> accountcode=RADIO
> hangtime=50
> althangtime=100
> totime=170000
> idtime=300000
> ;politeid=3000
> linktolink=1
> idtalkover=|iG0FHM F
> unlinkedct=ct1
> remotect=ct1
> remotetx=ct1
> linkunkeyct=ct1
> nolocallinkct=1
> ;eannmode=1
> ;connpgm=yourconnectprogram
> ;discpgm=yourdisconnectprogram
> ;lnkactenable=0
> ;lnkacttime=1800
> ;lnkactmacro=*52
> ;lnkacttimerwarn=30seconds
> ;remote_inact_timeout=1800
> ;remote_timeout=3600
> nounkeyct=0
> holdofftelem=0
> ;beaconing=1
> ;
> ; *** Status Reporting ***
> ;
> ; Uncomment the either group following two statpost lines to report 
> the status of your node to stats.allstarlink.org
> ; depending on whether you are running ACID or Limey Linux.
>
> ; ** For ACID ***
> statpost_program=/usr/bin/wget,-q,--timeout=15,--tries=1,--output-document=/dev/null 
>
> statpost_url=http://stats.allstarlink.org/uhandler.php ; Status updates
>
> ; ** For Limey Linux **
> ;statpost_program=/bin/wget,-q,--timeout=15,--tries=1,--output-document=/dev/null 
>
> ;statpost_url=http://stats.allstarlink.org/uhandler.php ; Status updates
>
> ;
> ; Morse code parameters, these are common to all repeaters.
> ;
>
> [morse29681]
>
> speed=30
> frequency=800
> amplitude=4096
> idfrequency=800
> idamplitude=1024
> [schedule29681]
> ;dtmf_function =  m h dom mon dow  ; ala cron, star is implied
> 80=00 * * * *
> 80=15 * * * *
> 80=30 * * * *
> 80=45 * * * *
> 81=00 * * * *
>
>
> [functions29681]
> 1=ilink,1
> 2=ilink,2
> 3=ilink,3
> 4=ilink,4
> 5=macro,1
> 70=ilink,5
> 71=ilink,6
> 72=ilink,7
> 73=ilink,15
> 74=ilink,16
> 75=ilink,8
>
> 80=status,1
> 81=status,2
>
> 6=autopatchup,noct=1,farenddisconnect=1,dialtime=20000  ; Autopatch up
> 0=autopatchdn                           ; Autopatch down
>
> 99=cop,43
> 980=status,3
> ;99=cop,6
>
> ; Place command macros here
>
> [macro29681]
> 80=*80
> 81=*81
>
> [telemetry]
>
> ;ct1=|t(350,0,100,2048)(500,0,100,2048)(660,0,100,2048)
> ct1=|t(2175,0,50,8192)
> ;ct2=|t(660,880,150,2048)
> ct2=|t(1633,0,50,3000)(0,0,80,0)(1209,0,50,3000)
> ct3=|t(2175,0,150,4096)
> ct4=|t(550,0,150,2048)
> ct5=|t(660,0,150,2048)
> ct6=|t(880,0,150,2048)
> ct7=|t(660,440,150,2048)
> ct8=|t(700,1100,150,2048)
> ;remotetx=|t(1633,0,50,3000)(0,0,80,0)(1209,0,50,3000)
> remotetx=|t(2175,0,150,8192)
> remotemon=|t(1209,0,50,2048)
> cmdmode=|t(900,903,200,2048)
> ;functcomplete=|t(1000,0,100,2048)(0,0,100,0)(1000,0,100,2048)
> functcomplete=|t(350,0,100,8192)(500,0,100,8192)(660,0,100,8192)
> ;functcomplete=|t(350,0,100,2048)(500,0,100,2048)(660,0,100,2048)
> ;functcomplete=|(2175,0,300,8192)
> patchup=rpt/callproceeding
> patchdown=rpt/callterminated
>
> ;
> ; This section allows wait times for telemetry events to be adjusted
> ; A section for wait times can be defined for every repeater
> ;
>
> [wait-times]
> telemwait=2750
> idwait=2750
> unkeywait=500
> calltermwait=2000
>
> ;
> ; This is where you define your nodes which cam be connected to.
>
> [nodes]
> ; Note, if you are using automatic update for allstar link nodes,
> ; no allstar link nodes should be defined here. Only place a definition
> ; for your locak nodes, and private (off of allstar link) nodes here.
>
> ;29681 = radio at 127.0.0.1/29681,NONE
>
> ; Memories for remote bases
>
> [memory]
>
> ;00 = 146.580,100.0,m
> ;01 = 147.030,103.5,m+t
> ;02 = 147.240,103.5,m+t
> ;03 = 147.765,79.7,m-t
> ;04 = 146.460,100.0,m
> ;05 = 146.550,100.0,m
>
>
> #includeifexists custom/rpt.conf
>
>
> _______________________________________________
> App_rpt-users mailing list
> App_rpt-users at ohnosec.org
> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20130624/c866eec8/attachment.html>


More information about the App_rpt-users mailing list