[App_rpt-users] USB Pointing problem- More info?

Doug Crompton doug at crompton.com
Fri Aug 28 20:37:56 EDT 2015


I am not sure if you are listening on the arm-allstar list. If not questions on the BBB/RPi2 should be asked there.

Did you follow the instructions on installing two  nodes on the RPi2 in the setup how-to on hamvoip.org? You need to follow the instructions in the initial setup and then NOT move the physical USB connections.
73 Doug
WA3DSP
http://www.crompton.com/hamradio


Date: Fri, 28 Aug 2015 20:27:03 +0000
From: kd8usf at yahoo.com
To: kk6ecm at gmail.com; App_rpt-users at ohnosec.org
Subject: Re: [App_rpt-users] USB Pointing problem- More info?

That brings up some questions I have about this- I have 2 interfaces on the Pi2 running Dougs image, sometimes when I reboot it, the two nodes both try to use the same interface even though they are configured in the tune files. Throws up errors in a continuous loop. When I restart asterisks from the command line it then works as it should and the two nodes are using their assigned interfaces. It's almost like the two interfaces are not fully initialized before asterisk starts on bootup. Now this is what lsusb shows:
Bus 001 Device 005: ID 0d8c:000c C-Media Electronics, Inc. Audio AdapterBus 001 Device 004: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter
When I used the tune menu to set the levels it wrote in the devices as follows:
For node 42051: devstr=1-1.4:1.0

For node 42078: devstr=1-1.5:1.0
Should I change that to 1-4 for node 42051, and 1-5 for node 42078? Andrew.

        From: kk6ecm <kk6ecm at gmail.com>
 To: chris <ckw at gci.net> 
Cc: "App_rpt-users at ohnosec.org" <App_rpt-users at ohnosec.org> 
 Sent: Wednesday, August 26, 2015 10:23 PM
 Subject: Re: [App_rpt-users] Allstar
   
You may have a USB pointing problem between asterisk and Linux.On boot up type "service asterisk stop" at the command promptType lsusb at the command prompt. [root at Xxxxxx~]# lsusbBus 004 Device 004: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio ControllerBus 004 Device 001: ID 0000:0000  Bus 004 Device 002: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio ControllerBus 001 Device 001: ID 0000:0000  Bus 003 Device 001: ID 0000:0000  Bus 002 Device 001: ID 0000:0000  Bus 005 Device 001: ID 0000:0000  Then make sure your tune files ( in /etc/asterisk) properly point to your USB device such as a URI in devstr=  (see below example)[root at xxxxx asterisk]# cat usbradio_tune_usb<node#>.conf[usb27178]; name=usb<node#>; devicenum=1devstr=4-2    ; Bus 004 Device 002: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controllerrxmixerset=125txmixaset=500txmixbset=500rxvoiceadj=1.820479rxctcssadj=0.500000txctcssadj=0rxsquelchadj=825Correct the tune file thenAt the command prompt type: service asterisk startThanks,Bobkk6ecmSent from iPad> On Aug 26, 2015, at 5:48 PM, chris <ckw at gci.net> wrote:> > Hello Again. I failed to mention The Allstar server is running ACID. After boot up It repeats the following ,> (asterisk) did not claim interface 3 before use. Forgot where to fix this. Thanks again. > > Chris> Allstar node 42264 > _______________________________________________> App_rpt-users mailing list> App_rpt-users at ohnosec.org> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users> > To unsubscribe from this list please visit http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button"> You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem. 

_______________________________________________App_rpt-users mailing listApp_rpt-users at ohnosec.orghttp://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-usersTo unsubscribe from this list please visit http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button"You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem. 

    
_______________________________________________
App_rpt-users mailing list
App_rpt-users at ohnosec.org
http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users

To unsubscribe from this list please visit http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button"
You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem. 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20150828/4c4be908/attachment.html>


More information about the App_rpt-users mailing list