[App_rpt-users] DIAL manual install from Debian

David McGough kb4fxc at inttek.net
Sun Dec 13 18:52:03 EST 2015


Hi Skyler,

This isn't Debian's fault. I run various Debian versions across dozens of 
servers, -all- of which run various forms of hardware RAID.

I recommend starting with the Debian net-install CD, downloaded from their 
website. Once Debian is running, then install Asterisk/AllStar. This isn't 
really too hard to do.

Since you mention the box is 10 years old, what kind of hardware and RAID 
controller have you got? ...Do you have true hardware RAID? Many 
inexpensive RAID solutions weren't truly "hardware" RAID controllers; 
rather they were software RAID, requiring special drivers. Most of those 
RAID systems should be avoided entirely, IMO, since they didn't tend to be 
very reliable.

Take a look at this link:

https://www.debian.org/CD/netinst/

If you have 32-bit x86 hardware, use this net-install image:

http://cdimage.debian.org/debian-cd/8.2.0/i386/iso-cd/debian-8.2.0-i386-netinst.iso

Or, if you've got a 64-bit CPU, try:

http://cdimage.debian.org/debian-cd/8.2.0/amd64/iso-cd/debian-8.2.0-amd64-netinst.iso

NOTE that some RAID controllers and other old hardware doesn't play well 
with a 64-bit OS version, even though the CPU is 64-bit capable. To be 
safe, going with the 32-bit OS version is probably the simplest path.

Good Luck-

73, David KB4FXC





On Sun, 13 Dec 2015, Skyler F wrote:

> The manual install is not working, and my RAID is not working either.
> 
> I plug in the URI and it flashes a few times and then is steady.
> Radio-tune-menu then does not work. The manual install also made my
> ethernet stop working so I had to go into a network conf file and add it
> back.
> 
> RAID 1 is not working either. I physically unplug a hard drive and boot it,
> and I get a bunch of errors.
> 
> CentOS plays a   l o t   better with RAID 1. ACID was previously installed
> and had no problem with the hardware raid.
> 
> Any suggestions of what to try next? I have tried N4IRS's script as well as
> W0JRL's debian install, none of them work. Right now I just disabled RAID
> and am installing DIAL on one of the disks, but I still want to use both so
> if one fails at the site.
> 
> How does one copy kernel modules to get the raid working?
> 
> This is server hardware.
> 
> On Sun, Dec 13, 2015 at 3:08 PM, Shamim Shahriar <shamim.shahriar at gmail.com>
> wrote:
> 
> >
> >
> > On 13/12/2015 18:49, Skyler F wrote:
> > > Does anybody have or know where there are scripts to install AllStar
> > > from Debian.
> > >
> > > For a setup for a repeater site  am using a server computer with two
> > > hard drives in a RAID1 configuration so if one is to fail on this 10
> > > year old machine, it will still work.
> > >
> > > I was not able to get DIAL installed but was able to get Debian to work.
> > >
> > > Thanks
> > > Skyler
> > > KD0WHB
> > >
> > Hi Skyler, this might not be an ideal solution, and you might have
> > already tried it. In cases like this , I have always found that that
> > installing the system on a known working system, later DD-ing the disc
> > image and booting into single user mode and fixing things so that
> > reflects the new hardware can also be an option. If the kernel versions
> > are the same, you might even be able to just copy over the kernel
> > modules required to have the raid working or other issues resolved. Have
> > you considered this option?
> >
> > Hope this helps
> > All the best.
> >
> > _______________________________________________
> > App_rpt-users mailing list
> > App_rpt-users at ohnosec.org
> > http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
> >
> > To unsubscribe from this list please visit
> > http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down
> > to the bottom of the page. Enter your email address and press the
> > "Unsubscribe or edit options button"
> > You do not need a password to unsubscribe, you can do it via email
> > confirmation. If you have trouble unsubscribing, please send a message to
> > the list detailing the problem.
> >
> 
> 
> 
> 




More information about the App_rpt-users mailing list