[App_rpt-users] Registration Issues

Bobby Lacey kf4gta at amsat.org
Wed Dec 23 22:16:59 EST 2015


Hi David,

Yes - source IP is the same 44/8 address that the allstar node is using for
registering.

[root at 146-760 ~]# wget http://ipinfo.io/ip -qO -
44.36.x.x

Just strange that it works for months, then stops all of a sudden?

Thanks for your help!

73

Bobby

On Wed, Dec 23, 2015 at 1:00 PM, David McGough <kb4fxc at inttek.net> wrote:

>
> Hi,
>
> I think you're hitting a security feature of the Registration System.
>
> When running wget (or the node info collection scripts, like:
> rc.updatenodelist), you must use the same source IP address as
> used during the Asterisk registration requests sent from Asterisk when it
> is running. And, your node must be properly registered to retrieve the
> node list.
>
> So, is the source IP address of the AllStar/Asterisk server on the
> 44.0.0.0/8 network?  And, if so, when running wget, do you use the same
> source IP address as Asterisk?  If not, these addresses must be the same.
>
>
> Merry Christmas and Happy Holidays!!
>
> 73, David KB4FXC
>
>
> On Wed, 23 Dec 2015, Bobby Lacey wrote:
>
> > Hello!
> >
> > Every few months, we run into a problem where our nodes will de-register
> > with register.allstarlink.org and just set there before timing out and
> > retrying. It never does register until it just magically starts working
> > again often many days later.
> >
> > I haven't really had time to troubleshooted it before, but since I'm home
> > from work for a few days, I'm trying to trace down the problem.
> >
> > Something interesting I've found: These nodes are sitting on my 44Net (
> > 44.0.0.0/8) address space and get the following when I try to wget
> nodes.pl:
> >
> > [root at 146-760 ~]# wget http://nodes1.allstarlink.org/cgi-bin/nodes.pl
> > --2015-12-23 11:36:23--  http://nodes1.allstarlink.org/cgi-bin/nodes.pl
> > Resolving nodes1.allstarlink.org (nodes1.allstarlink.org)...
> 96.36.57.202
> > Connecting to nodes1.allstarlink.org
> > (nodes1.allstarlink.org)|96.36.57.202|:80...
> > connected.
> > HTTP request sent, awaiting response... 403
> > 2015-12-23 11:36:23 ERROR 403: (no description).
> >
> > [root at 146-760 ~]# wget http://nodes2.allstarlink.org/cgi-bin/nodes.pl
> > --2015-12-23 11:36:57--  http://nodes2.allstarlink.org/cgi-bin/nodes.pl
> > Resolving nodes2.allstarlink.org (nodes2.allstarlink.org)...
> 209.159.155.200
> > Connecting to nodes2.allstarlink.org
> > (nodes2.allstarlink.org)|209.159.155.200|:80...
> > connected.
> > HTTP request sent, awaiting response... 403 Forbidden
> > 2015-12-23 11:36:57 ERROR 403: Forbidden.
> >
> > [root at 146-760 ~]# wget http://nodes3.allstarlink.org/cgi-bin/nodes.pl
> > --2015-12-23 11:37:28--  http://nodes3.allstarlink.org/cgi-bin/nodes.pl
> > Resolving nodes3.allstarlink.org (nodes3.allstarlink.org)...
> 65.110.110.172
> > Connecting to nodes3.allstarlink.org
> > (nodes3.allstarlink.org)|65.110.110.172|:80...
> > connected.
> > HTTP request sent, awaiting response... 403
> > 2015-12-23 11:37:28 ERROR 403: (no description).
> >
> >
> > When I try from my ISP's public IP (non 44Net), it works fine. This is
> just
> > an observation and I'm not sure if it actually is the problem.
> >
> >  Anyone have any ideas?
> >
> > Tnx and 73
> >
> > Bobby
> > KF4GTA
> >
>
> _______________________________________________
> App_rpt-users mailing list
> App_rpt-users at ohnosec.org
> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>
> To unsubscribe from this list please visit
> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down
> to the bottom of the page. Enter your email address and press the
> "Unsubscribe or edit options button"
> You do not need a password to unsubscribe, you can do it via email
> confirmation. If you have trouble unsubscribing, please send a message to
> the list detailing the problem.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20151223/a82f2ad2/attachment.html>


More information about the App_rpt-users mailing list