[App_rpt-users] USB Adapter has no EEPROM installed

Larry da Ponte hb9eyq at gmail.com
Sun Nov 1 06:21:07 EST 2015


Two questions for the group:

#1 I'm seeing this in my /var/log/asterisk - I'm using a DMK URI with
EEPROM and a Motorola GM300 with one of Marshall's Motorola Maxtrac, GM300
and M120 16 Pin Radio to URI cables.

[Nov  1 11:30:05] NOTICE[6852] chan_usbradio.c: USB Adapter has no EEPROM
installed or Checksum BAD on channel usb42372

I understand that the benefit of the DMK URI with EEPROM is that the
interface configuration can be stored in the URI as apposed to (where
else?) - is this URI EEPROM feature taken advantage of with app_rpt and
associated drivers?

#2 How do I choose which channel driver to use - simpleusb or USBRadio?
>From what I've been able to learn through varius wikis and posts on the
subject, I would want to use simpleusb because all of the hardware
connections for COS and CTCSS are provided so there is no reason to use the
DSP features of USBRadio thus simplifying what the driver has to do and
perhaps lowering the CPU utilization.  I've also read some posts that
describe audio degredation in the USBRadio driver but I can't tell you the
cause.  I expect the right answer here is for me to try out both and
experiment - which I will do but would appreciate any wisdome from the
group on their experience with these drivers when using the DMK URI and
hardware connections for COS/CTCSS.  My current configuration below is
getting favorable audio reports.

I have no simpleusb.conf in my /etc/asterisk
I have usbradio.conf and usbradio_tune_usb42372.conf

I have the following in my rpt.conf: rxchannel=Radio/usb42372

I have the following in my usbradio.conf:

[usb42372]

hdwtype=0
rxboost=1
txboost=1
rxctcssrelax=1
txctcssdefault=71.9
rxctcssfreqs=71.9
txctcssfreqs=71.9
;rxctcssoverride=0
carrierfrom=dsp
ctcssfrom=dsp
rxdemod=flat
txprelim=yes
txlimonly=no
txtoctype=notone
txmixa=composite
txmixb=no
invertptt=0
duplex=0
rxondelay=0
rxnoisefiltype=0
eeprom=1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20151101/258ae385/attachment.html>


More information about the App_rpt-users mailing list