[App_rpt-users] I think we slightly touched on this topic but need a refresher

Mike - W5JR w5jr.lists at gmail.com
Mon Feb 29 22:02:03 EST 2016


And that is in extensions.conf

tnx
Mike / W5JR
Alpharetta GA

> On Feb 29, 2016, at 7:26 PM, Loren Tedford <lorentedford at gmail.com> wrote:
> 
> I am playing around with iaxrpt and have added the following lines to my 
> extensions.conf
> [globals]
> HOMENPA=200
> NODE=41715
> NODE2=41834
> NODE3=27103
> NODE4=42448
> 
> 
> 
> [iax-client]				; for IAX VIOP clients
> exten => ${NODE},1,Ringing
> exten => ${NODE},n,Wait(3)
> exten => ${NODE},n,Answer
> exten => ${NODE},n,Set(NODENUM=${CALLERID(number)})
> exten => ${NODE},n,Playback(rpt/node|noanswer)
> exten => ${NODE},n,SayDigits(${EXTEN})
> exten => ${NODE},n,Set(CALLERID(num)=0)
> exten => ${NODE},n,Rpt,${NODE}|P|${CALLERID(name)}
> exten => ${NODE},n,Hangup
> exten => ${NODE},n(hangit),Answer
> exten => ${NODE},n(hangit),Wait(1)
> exten => ${NODE},n(hangit),Hangup
> 
> [iax-client2]				; for IAX VIOP clients
> exten => ${NODE2},1,Ringing
> exten => ${NODE2},n,Wait(3)
> exten => ${NODE2},n,Answer
> exten => ${NODE2},n,Set(NODENUM=${CALLERID(number)})
> exten => ${NODE2},n,Playback(rpt/node|noanswer)
> exten => ${NODE2},n,SayDigits(${EXTEN})
> exten => ${NODE2},n,Set(CALLERID(num)=0)
> exten => ${NODE2},n,Rpt,${NODE}|P|${CALLERID(name)}
> exten => ${NODE2},n,Hangup
> exten => ${NODE2},n(hangit),Answer
> exten => ${NODE2},n(hangit),Wait(1)
> exten => ${NODE2},n(hangit),Hangup
> 
> [iax-client3]                           ; for IAX VIOP clients
> exten => ${NODE3},1,Ringing
> exten => ${NODE3},n,Wait(3)
> exten => ${NODE3},n,Answer
> exten => ${NODE3},n,Set(NODENUM=${CALLERID(number)})
> exten => ${NODE3},n,Playback(rpt/node|noanswer)
> exten => ${NODE3},n,SayDigits(${EXTEN})
> exten => ${NODE3},n,Set(CALLERID(num)=0)
> exten => ${NODE3},n,Rpt,${NODE}|P|${CALLERID(name)}
> exten => ${NODE3},n,Hangup
> exten => ${NODE3},n(hangit),Answer
> exten => ${NODE3},n(hangit),Wait(1)
> exten => ${NODE3},n(hangit),Hangup
> 
> [iax-client4]                           ; for IAX VIOP clients
> exten => ${NODE4},1,Ringing
> exten => ${NODE4},n,Wait(3)
> exten => ${NODE4},n,Answer
> exten => ${NODE4},n,Set(NODENUM=${CALLERID(number)})
> exten => ${NODE4},n,Playback(rpt/node|noanswer)
> exten => ${NODE4},n,SayDigits(${EXTEN})
> exten => ${NODE4},n,Set(CALLERID(num)=0)
> exten => ${NODE4},n,Rpt,${NODE}|P|${CALLERID(name)}
> exten => ${NODE4},n,Hangup
> exten => ${NODE4},n(hangit),Answer
> exten => ${NODE4},n(hangit),Wait(1)
> exten => ${NODE4},n(hangit),Hangup
> 
> 
> 
> I added the following lines to my iax.conf 
> 
> [username]                     	; Connect from iax client (Zoiper...)
> type=friend                     	; Notice type here is friend <--------------
> context=iax-client              	; Context to jump to in extensions.conf
> auth=md5
> secret=password
> host=dynamic
> disallow=all
> allow=ulaw
> allow=g726aal2
> allow=gsm
> transfer=no
> 
> [username2]                     	; Connect from iax client (Zoiper...)
> type=friend                     	; Notice type here is friend <--------------
> context=iax-client2             	; Context to jump to in extensions.conf
> auth=md5
> secret=password
> host=dynamic
> disallow=all
> allow=ulaw
> allow=g726aal2
> allow=gsm
> transfer=no
> 
> [username3]                     	; Connect from iax client (Zoiper...)
> type=friend                     	; Notice type here is friend <--------------
> context=iax-client3              	; Context to jump to in extensions.conf
> auth=md5
> secret=password
> host=dynamic
> disallow=all
> allow=ulaw
> allow=g726aal2
> allow=gsm
> transfer=no
> 
> [username4]                     	; Connect from iax client (Zoiper...)
> type=friend                     	; Notice type here is friend <--------------
> context=iax-client4              	; Context to jump to in extensions.conf
> auth=md5
> secret=password
> host=dynamic
> disallow=all
> allow=ulaw
> allow=g726aal2
> allow=gsm
> transfer=no
> 
> I am trying to use the Andriod iax client and it only connects to node 41715 and to no other nodes why is this??
> 
> 
> 
> Loren Tedford (KC9ZHV) 
> Email: lorentedford at gmail.com
> http://www.lorentedford.com
> http://www.kc9zhv.com
> http://forum.kc9zhv.com
> http://hub.kc9zhv.com
> http://www.newwavesucks.com
> http://forum.newwavesucks.com
> _______________________________________________
> App_rpt-users mailing list
> App_rpt-users at ohnosec.org
> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
> 
> To unsubscribe from this list please visit http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button"
> You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20160229/e3e33c59/attachment.html>


More information about the App_rpt-users mailing list