[App_rpt-users] Android IAXRPT stuck PTT

Jim Duuuude telesistant at hotmail.com
Fri Jul 22 12:29:12 EDT 2016


As we all (obviously) know, VOIP protocols, such as IAX2, may be used for

transport of audio/signalling for uses other then phone calls, such as radio, in this case.


Therefore, an endpoint that accepts a VOIP connection processes/utilizes different

methodologies for a radio connection and a "traditional telephony" (like a phone call)

type of connection.


The "X" is used for a radio-style connection, and indicates to app_rpt that it is not to authenticate

the call (that is, authentication was done in the dialplan previous to "sending" it to app_rpt). This is

necessary for scenarios such as use with IAXRPT, where user authentication is done via means external

to app_rpt.


The "P" is used to make app_rpt accept a "traditional" telephony-style (VOIP SIP, IAX2, etc, or other telephony

interface, such as DAHDI) connection, and allow access to a node via a "telephone" call.


These are 2 very different operating environments.


Jim

________________________________
From: app_rpt-users-bounces at ohnosec.org <app_rpt-users-bounces at ohnosec.org> on behalf of Tom Hayward <tom at tomh.us>
Sent: Friday, July 22, 2016 9:10 AM
To: Steve Zingman
Cc: app_rpt-users at ohnosec.org
Subject: Re: [App_rpt-users] Android IAXRPT stuck PTT

On Fri, Jul 22, 2016 at 8:44 AM, Steve Zingman <szingman at msgstor.com> wrote:
> Opps, Sorry.
> Add NODE = 41702 above it.

As you can tell, I'm very new to this and unfamiliar with the standard
variables, etc. Okay, added NODE = 41702 to the [globals] stanza and
now it works! I tried a few connects/disconnects and had no odd PTT
behavior.

Then I went back and removed the Playback commands as I prefer. It still works.

What is the difference between the P and X option in the Rpt command?
That seems to be the major difference here. All of the tutorials I found use X.
I have a hard time finding canon documentation for this stuff.

By the way, I was able to break (node graph was missing)
http://stats.allstarlink.org/getstatus.cgi?41702 by putting a space in
the CallerID. I guess that's not allowed.

Thanks for your help. The quick replies made for easy troubleshooting.

Tom KD7LXL
_______________________________________________
App_rpt-users mailing list
App_rpt-users at ohnosec.org
http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users

To unsubscribe from this list please visit http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button"
You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20160722/70228487/attachment.html>


More information about the App_rpt-users mailing list