[App_rpt-users] Reverse AutoPatch

JJC cummingsj at gmail.com
Wed Mar 30 20:34:51 EDT 2016


It's all one big mess, yes I did need that also.. It seems that when I make changes even to my reverse auto patch it affects the error that I noted.  Thanks for the info for sure!

Sent from the iRoad

> On Mar 30, 2016, at 18:26, Jim Duuuude <telesistant at hotmail.com> wrote:
> 
> No, that's a SIP problem, I thought you were needing info on the reverse autopatch.
> 
> 
> From: JJC <cummingsj at gmail.com>
> Sent: Wednesday, March 30, 2016 5:24 PM
> To: Jim Duuuude
> Cc: app_rpt-users at ohnosec.org
> Subject: Re: [App_rpt-users] Reverse AutoPatch
>  
> This will address the "found no matching peer or user" error?
> 
> Sent from the iRoad
> 
> On Mar 30, 2016, at 17:10, Jim Duuuude <telesistant at hotmail.com> wrote:
> 
>> A real, live example is in extensions.conf, just after the beginning of the [allstar-sys] stanza:
>> 
>> 
>> exten => _1.,1,Rpt(${EXTEN:1}|Rrpt/node:NODE:rpt/in-call:digits/0:PARKED|120) 75
>> 
>> exten => _1.,n,Hangup
>> 
>> 
>> In this case, it is passed 1 plus the node number as an extension. If you replace "${EXTEN:1}" with your node
>> 
>> number it should work.
>> 
>> 
>> Jim
>> 
>> 
>> From: app_rpt-users-bounces at ohnosec.org <app_rpt-users-bounces at ohnosec.org> on behalf of JJC <cummingsj at gmail.com>
>> Sent: Wednesday, March 30, 2016 3:21 PM
>> To: app_rpt-users at ohnosec.org
>> Subject: [App_rpt-users] Reverse AutoPatch
>>  
>> I have scoured the internet to find documentation about reverse autopatch but have had no luck.  I have been able to get autopatch working without a problem and have had _limited_ success in getting allstar(dial) to answer.
>> 
>> I was able to get allstar to answer and allow me to run DTMF with the following, but really all that I want is reverse autopatch or both....
>> 
>> If I make any real changes to the stanza in extensions.conf I get an error like:
>> Using INVITE request as basis request - 1939985154 at 198.199.84.66
>> Found no matching peer or user for '198.199.84.66:5060'
>> [Mar 30 16:15:32] NOTICE[575]: chan_sip.c:14351 handle_request_invite: Failed to authenticate user "Caller ID Strings..."
>> 
>> <sip.conf>
>> [general]
>> allowguest = no
>> match_auth_username=yes
>> register=REDACTED:XXXXXX at gvgw.simonics.com/2230
>> 
>> context = default
>> allowoverlap = no               ; Disable overlap dialing support. (Default is yes)
>> bindport = 5060                 ; UDP Port to bind to (SIP standard port is 5060)
>> bindaddr = 0.0.0.0              ; IP address to bind to (0.0.0.0 binds to all)
>> srvlookup = yes                 ; Enable DNS SRV lookups on outbound calls
>> 
>> 
>> [GV17193576518]
>> type=friend
>> autocreatepeer=yes
>> insecure=port,invite
>> username=REDACTED
>> secret=XXXXXXX
>> host=gvgw.simonics.com
>> qualify=no
>> ;permit=0.0.0.0/0.0.0.0
>> context=custom-gv-answer
>> 
>> <extensions.conf>
>> [custom-gv-answer]
>> exten => 2230,1,Answer()
>> exten => 2230,n,Playback(rpt/node)
>> exten => 2230,n,Saydigits(${EXTEN:1})
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20160330/dcfa2c39/attachment.html>


More information about the App_rpt-users mailing list