[App_rpt-users] Registration Check

Steve Mahler kizzy at lusfiber.net
Sat Nov 19 18:18:16 EST 2016


This issue has been resolved with the help of M0HOY.  The fixing step 
was changing a home router so the Port Forwarding for 5679 was listed as 
UDP instead of BOTH (udp & ip).  I don't understand why this worked, but 
I am happy.

...STeve


On 11/19/2016 1:02 PM, Steve Mahler wrote:
>
> Stephen:
>
> Wow, changing from BOTH to UDP made it work.  Crazy and doesn't bode 
> well for the ASUS home router software!  THANK-YOU for your assistance.
>
> ...STeve
>
>
> On 11/19/2016 12:31 PM, Stephen Curtis wrote:
>> Ha Ha,
>>
>> No if they are on different public IP addresses none of what I have 
>> said applies! :)
>>
>> What I would suggest is that you set your 4569 ports to UDP not not both.
>>
>> when you are in the CLI>
>> do an iax2 show registry
>>
>> Just to check they are both registered correctly with allstar.
>>
>>
>> Steve :)
>>
>>
>>
>>
>>> On 19 Nov 2016, at 18:25, Steve Mahler <kizzy at lusfiber.net 
>>> <mailto:kizzy at lusfiber.net>> wrote:
>>>
>>> Stephen:
>>>
>>> Nuts, I guess I should have mentioned that the two servers (each 
>>> with one node) are on two different public IP addresses.  So, does 
>>> your suggestion still apply?
>>>
>>> ...STeve
>>>
>>>
>>> On 11/19/2016 12:07 PM, Stephen Curtis wrote:
>>>> Ok what you need to do is change the bind port for your second node 
>>>> to 4568 because they can’t both be on the same port. You will need 
>>>> to add this as a UDP port in your router and also change from 4569 
>>>> to 4568 on the allstarlink.org <http://allstarlink.org/> website 
>>>> under network settings.
>>>>
>>>> node 42316
>>>>
>>>> It is at the top of the config file:
>>>>
>>>> iax.conf
>>>>
>>>> bindport=4568
>>>>
>>>> Then in the rpt.conf for each node you will need:
>>>>
>>>>> rpt.conf for 42315 ...
>>>>>
>>>>> 42315 = radio at 127.0.0.1:4569/42315,NONE
>>>>>
>>>>> 42316 =  radio at ipaddress:4568/42316,NONE
>>>>
>>>>
>>>>> rpt.conf for 42316 ...
>>>>>
>>>>> 42316 = radio at 127.0.0.1:4568/42316,NONE
>>>>>
>>>>> 42315 = radio at ipaddress:4569/42315,NONE
>>>>
>>>>
>>>>
>>>>
>>>> Cheers
>>>>
>>>> Steve
>>>>
>>>>
>>>>
>>>>
>>>>> On 19 Nov 2016, at 17:42, Steve Mahler <kizzy at lusfiber.net 
>>>>> <mailto:kizzy at lusfiber.net>> wrote:
>>>>>
>>>>> Stephen:
>>>>>
>>>>> Thanks for the reply.  Each node number is on its own server.
>>>>>
>>>>> On each server ...
>>>>>
>>>>> rpt.conf for 42315 ...
>>>>>
>>>>> 42315 = radio at 127.0.0.1:4569/42315,NONE
>>>>>
>>>>> rpt.conf for 42316 ...
>>>>>
>>>>> 42316 = radio at 127.0.0.1:4569/42316,NONE
>>>>>
>>>>> iax.conf for each node (on separate servers) have the registration 
>>>>> line
>>>>>
>>>>> in 42315 ...  register = 42315:000000 at register.allstarlink.org (pw 
>>>>> changed)
>>>>>
>>>>> in 42316 ...  register = 42316:111111 at register.allstarlink.org (pw 
>>>>> changed)
>>>>>
>>>>> The FAQ points to checking the registration in the AllStar DB. 
>>>>> Apparently a "forcing" of port 4569 is necessary in some cases.  
>>>>> That is what I am trying to run down.
>>>>>
>>>>> Thanks again,
>>>>>
>>>>> ...STeve
>>>>>
>>>>>
>>>>> On 11/19/2016 10:45 AM, Stephen Curtis wrote:
>>>>>> Sorry, forgot to check if both nodes are on the same machine?
>>>>>>
>>>>>> Cheers
>>>>>>
>>>>>> Steve M0HOY
>>>>>>
>>>>>>
>>>>>>> On 19 Nov 2016, at 16:15, Steve Mahler <kizzy at lusfiber.net 
>>>>>>> <mailto:kizzy at lusfiber.net>> wrote:
>>>>>>>
>>>>>>> Morning!  I have two nodes (42315 and 42316).  Both nodes can 
>>>>>>> connect outbound to other servers).
>>>>>>>
>>>>>>> 1)  Node 42315 can connect outbound to 42316.
>>>>>>>
>>>>>>> 2)  Node 42316 can NOT connect outbound to 42315.
>>>>>>>
>>>>>>> 3)  I've checked the 42315 router ...  ASUS router ... 
>>>>>>> portforwarding shown  below.
>>>>>>>
>>>>>>> 4)  Looking for someone to confirm that 42315 is properly 
>>>>>>> registered in the DB.
>>>>>>>
>>>>>>> ...STeve - KF5VH
>>>>>>>
>>>>>>>
>>>>>>> Service Name 	Port Range <javascript:void(0);> 	Local IP 
>>>>>>> <javascript:void(0);> 	Local Port <javascript:void(0);> 	Protocol
>>>>>>>
>>>>>>>
>>>>>>> ALLSTAR-IAX 	4569 	192.168.1.199 	4569 	BOTH 	
>>>>>>> ECHOLINK-5198 	5198 	192.168.1.199 	5198 	BOTH 	
>>>>>>> ECHOLINK-5199 	5199 	192.168.1.199 	5199 	BOTH 	
>>>>>>> ALLSTAR-API 	5038 	192.168.1.199 	5038 	BOTH
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> App_rpt-users mailing list
>>>>>>> App_rpt-users at ohnosec.org <mailto:App_rpt-users at ohnosec.org>
>>>>>>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
>>>>>>>
>>>>>>> To unsubscribe from this list please visit 
>>>>>>> http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users and 
>>>>>>> scroll down to the bottom of the page. Enter your email address 
>>>>>>> and press the "Unsubscribe or edit options button"
>>>>>>> You do not need a password to unsubscribe, you can do it via 
>>>>>>> email confirmation. If you have trouble unsubscribing, please 
>>>>>>> send a message to the list detailing the problem.
>>>>>>
>>>>>
>>>>
>>>
>>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20161119/33c93517/attachment.html>


More information about the App_rpt-users mailing list