[App_rpt-users] RTCM Going Off Line - Trimble Loosing Lock

Steve Zingman szingman at msgstor.com
Sun Jul 16 15:09:46 EDT 2017


I'll be happy to take whatevery you guys have and put it into the wiki 
on github along with the source.
There are a number of people either working on or getting setup to work 
on the code. It would be nice to have this all in one place.

73, Steve N4IRS

On 07/16/2017 02:28 PM, Joe Moskalski wrote:
> I will stick this info in my wiki if you don't mind.
>
> On Jul 16, 2017 2:01 PM, "Lee Woldanski" <ve7fet at tparc.org 
> <mailto:ve7fet at tparc.org>> wrote:
>
>     Hi Tim,
>
>     I dug in to the source to help figure this out... someone should
>     put this in a wiki somewhere...
>
>     The VOTER/RTCM when in TSIP mode (Trimble), assumes it is a
>     Trimble Thunderbolt and is looking for two packets:
>
>     0x8F-AB - Primary Timing Packet
>     0x8F-AC - Supplemental Timing Packet
>
>     Grab a copy of the Thunderbolt User Guide:
>     http://leapsecond.com/pages/tbolt/Thunderbolt-2012-02.pdf
>     <http://leapsecond.com/pages/tbolt/Thunderbolt-2012-02.pdf>
>
>     Pages 78-83 are the important ones.
>
>     Packet 0x8F-AB is what grabs the timing information, and packet
>     0x8F-AC is what it looks at for everything else (including debug).
>
>     The debug string that the VOTER/RTCM reports:
>
>     printf("GPS-DEBUG: TSIP: ok %d, 9 - 14: %02x %02x %02x %02x %02x
>     %02x\n",
>     happy,gps_buf[9],gps_buf[10],gps_buf[11],gps_buf[12],gps_buf[13],gps_buf[14]);
>
>     So, the 1 after ok is the "happy.gps" flag. The other 5 bytes are
>     supposed to be bytes 9-14 from the packet... sort of. They are
>     bytes 9-14 of the buffer, but they are actually bytes 8-13 of the
>     message.
>
>     Looking at the message structure, bytes 8-13 are:
>
>     8-9 Critical Alarms
>     10-11 Minor Alarms
>     12 GPS Decoding Status
>     13 Disciplining Activity
>
>     Therefore, the messages you are seeing break down as follows:
>
>     GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00 - everything is
>     good in the 'hood, Doing Fixes, Phase Locking
>
>     GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 18 08 06 - not happy, Not
>     Tracking Satellites, Not Disciplining Oscillator (0x18 -->
>     0b000000011000), No Usable Sats, Inactive
>
>     GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 08 08 05 - not happy, Not
>     Tracking Satellites, No Useable Sats, Compensating OXCO (holdover)
>
>     GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 05 - not happy,
>     Compensating OXCO (holdover)
>
>     GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08 - happy, Recovery
>     Mode
>
>     GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 04 - not happy,
>     Initializing Loop Filter
>
>
>     Why you are losing lock... can't help you there. Perhaps you have
>     an antenna going bad, wet feedline, LNA in the antenna not
>     receiving voltage, sky obstruction, or interference.
>
>
>     Cheers!
>
>
>     Lee
>
>
>     On Mon, Jul 10, 2017 at 1:49 PM, Tim Sawyer <tisawyer at gmail.com
>     <mailto:tisawyer at gmail.com>> wrote:
>
>         There is a pattern to the debug out put which looks like
>         below. Sure would like to decode this:
>
>         It's happy when there are all zeros. Then it does 18 08 06
>
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 18 08 06
>         07/10/2017 20:35:42.100  GPS signal lost entirely. Starting
>         again...
>         07/10/2017 20:35:42.100  Host Connection Lost (Pri) (192.168.1.6)
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 08 08 05
>         GPS Receiver Active, waiting for aquisition
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 08 08 05
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 08 08 05
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 08 08 05
>
>         Repeats, trimmed for brevity.
>
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 08 08 05
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 08 08 05
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 05
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 05
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 05
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 05
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 05
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         GPS signal acquired
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         07/10/2017 20:36:03.100  Time now syncronized to GPS
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         07/10/2017 20:36:03.500  Host Connection established (Pri)
>         (192.168.1.6)
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>
>         Repeats, trimmed for brevity.
>
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 04
>         07/10/2017 20:36:52.200  GPS signal lost entirely. Starting
>         again...
>         07/10/2017 20:36:52.220  Host Connection Lost (Pri) (192.168.1.6)
>         GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 04
>         GPS Receiver Active, waiting for aquisition
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>         GPS signal acquired
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>         07/10/2017 20:36:56.220  Time now syncronized to GPS
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>         07/10/2017 20:36:56.500  Host Connection established (Pri)
>         (192.168.1.6)
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>         GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>
>         Now it will have all zeros until the next loss, which could be
>         minutes or hours.
>
>         On Mon, Jul 10, 2017 at 1:29 PM, Jesse Lloyd <ve7lyd at gmail.com
>         <mailto:ve7lyd at gmail.com>> wrote:
>
>             I've had problems with the VHF transmitter antennas being
>             too close to the GPS antenna and RF swamping it. If you go
>             to site and use the Trimble software to see satellite
>             signal data then key the transmitter, mine would show a
>             loss of almost all the satellites.
>
>             Cheers,
>             Jesse
>
>             On Jul 10, 2017, at 1:17 PM, Tim Sawyer
>             <tisawyer at gmail.com <mailto:tisawyer at gmail.com>> wrote:
>
>>             My RTCM, two of then actually on the same Trimble, are
>>             loosing lock of late. The output from the RTCM Debug mode
>>             40 is shown below. I read that all zeros was good but I'm
>>             wondering 08 and 04 in the last byte mean. Does any know
>>             how to decode this?
>>
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 08
>>
>>             GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 04
>>
>>             07/10/2017 20:08:22.160  GPS signal lost entirely.
>>             Starting again...
>>
>>             07/10/2017 20:08:22.160  Host Connection Lost (Pri)
>>             (192.168.1.6)
>>
>>             GPS-DEBUG: TSIP: ok 0, 9 - 14: 00 00 00 00 00 04
>>
>>             GPS Receiver Active, waiting for aquisition
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>>
>>             GPS signal acquired
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>>
>>             07/10/2017 20:08:26.160  Time now syncronized to GPS
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>>
>>             07/10/2017 20:08:26.500  Host Connection established
>>             (Pri) (192.168.1.6)
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>>
>>             GPS-DEBUG: TSIP: ok 1, 9 - 14: 00 00 00 00 00 00
>>
>>
>>
>>             -- 
>>             --
>>             Tim
>>             _______________________________________________
>>             App_rpt-users mailing list
>>             App_rpt-users at lists.allstarlink.org
>>             <mailto:App_rpt-users at lists.allstarlink.org>
>>             http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>>             <http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users>
>>
>>             To unsubscribe from this list please visit
>>             http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>>             <http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users>
>>             and scroll down to the bottom of the page. Enter your
>>             email address and press the "Unsubscribe or edit options
>>             button"
>>             You do not need a password to unsubscribe, you can do it
>>             via email confirmation. If you have trouble
>>             unsubscribing, please send a message to the list
>>             detailing the problem.
>
>             _______________________________________________
>             App_rpt-users mailing list
>             App_rpt-users at lists.allstarlink.org
>             <mailto:App_rpt-users at lists.allstarlink.org>
>             http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>             <http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users>
>
>             To unsubscribe from this list please visit
>             http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>             <http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users>
>             and scroll down to the bottom of the page. Enter your
>             email address and press the "Unsubscribe or edit options
>             button"
>             You do not need a password to unsubscribe, you can do it
>             via email confirmation. If you have trouble unsubscribing,
>             please send a message to the list detailing the problem.
>
>
>
>
>         -- 
>         --
>         Tim
>
>         _______________________________________________
>         App_rpt-users mailing list
>         App_rpt-users at lists.allstarlink.org
>         <mailto:App_rpt-users at lists.allstarlink.org>
>         http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>         <http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users>
>
>         To unsubscribe from this list please visit
>         http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>         <http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users>
>         and scroll down to the bottom of the page. Enter your email
>         address and press the "Unsubscribe or edit options button"
>         You do not need a password to unsubscribe, you can do it via
>         email confirmation. If you have trouble unsubscribing, please
>         send a message to the list detailing the problem.
>
>
>
>
>     -- 
>     Lee Woldanski, AScT
>     VE7FET
>
>     _______________________________________________
>     App_rpt-users mailing list
>     App_rpt-users at lists.allstarlink.org
>     <mailto:App_rpt-users at lists.allstarlink.org>
>     http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>     <http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users>
>
>     To unsubscribe from this list please visit
>     http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>     <http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users>
>     and scroll down to the bottom of the page. Enter your email
>     address and press the "Unsubscribe or edit options button"
>     You do not need a password to unsubscribe, you can do it via email
>     confirmation. If you have trouble unsubscribing, please send a
>     message to the list detailing the problem.
>
>
>
> _______________________________________________
> App_rpt-users mailing list
> App_rpt-users at lists.allstarlink.org
> http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>
> To unsubscribe from this list please visit http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button"
> You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20170716/78cb38f0/attachment.html>


More information about the App_rpt-users mailing list