[App_rpt-users] RTCM RSSI calibration (recorder)

Chuck Henderson rpt2 at chuck.midlandsnetworking.com
Thu Oct 26 09:53:31 EDT 2017


I do not use the rpi for any repeaters yet. I do not specify /tmp, but my
files automatically are placed in /tmp.
I suspect that in porting the code to the rpi there must have been a change
in the source code that changed that behavior.
Maybe by default, they send files to /dev/null to avoid using up the
limited writes to the flash memory???
Can you plug in a usb hard drive to capture logs and recordings so as to
save the flash memory from eventual destruction from too many writes?
So far I have lost 3 flash cards in experimental rpi use.  I think each
location in the flash is limited to a finite number of writes (maybe
100,000 per location) and software tries to keep moving files around to use
up the entire flash evenly.  But they do eventually fail.
Chuck





On Wed, Oct 25, 2017 at 5:35 AM, Hayden Honeywood <haydenph91 at gmail.com>
wrote:

> Fixed it! Silly me.
>
> #!/bin/sh
> asterisk -r -x "voter record 1727 /tmp/voter-recordRTC"`date +%F-%H-%M` >> /var/log/voterrecordlog
>
> The path needs to be defined in the command.
>
> Will post all this to the wiki soon.
>
> Hayden
>
>
>
> On Wed, Oct 25, 2017 at 8:40 PM, Hayden Honeywood <haydenph91 at gmail.com>
> wrote:
>
>> Thanks Chuck.
>>
>> My /tmp directory isn't filling up with any files at all. I made sure
>> there had been voter receiver activity, and ran the script a few times. In
>> the log it shows a new filename everytime I run it.
>>
>> Went directly into the command line and ran:
>> voter record 1727 voter-recordRTC1
>>
>> I get back:
>> voter instance 1727 Record: Recording enabled info file voter-recordRTC1
>>
>> Check activity, then send the same command with 2 at the end of the
>> filename to change. Nothing appears in /tmp. I did a complete search on the
>> Pi for everything with the name voter in it, and still cannot find the
>> recordings.
>>
>> I also have a tmpfs that I will have to make bigger once I get it
>> working  25M  8.0K   25M   1% /tmp
>>
>>
>>
>>
>
> _______________________________________________
> App_rpt-users mailing list
> App_rpt-users at lists.allstarlink.org
> http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
>
> To unsubscribe from this list please visit http://lists.allstarlink.org/
> cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of
> the page. Enter your email address and press the "Unsubscribe or edit
> options button"
> You do not need a password to unsubscribe, you can do it via email
> confirmation. If you have trouble unsubscribing, please send a message to
> the list detailing the problem.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20171026/4bd0ac98/attachment.html>


More information about the App_rpt-users mailing list