[App_rpt-users] Install Allstarlink on Debian 9 VPS

Monty monty at ke7jvx.com
Fri Apr 6 19:15:04 EDT 2018


Hello All,

I'm trying to install the allstarlink package on my Debian VPS.  I followed
the instructions on the wiki:

cd /tmp
wget https://github.com/AllStarLink/Asterisk/raw/develop/allstar/repository/install-repository
chmod +x install-repository
./install-repository

If Raspbian: apt-get install raspberrypi-kernel-headers -y

Otherwise: apt-get install linux-headers-`uname -r` -y

apt-get update
apt-get install allstarlink -y

I did get an error on the *linux-headers* command.  I installed what I
believe is the latest headers from apt-get (4.9.0-6-amd64).

Asterisk is not able to run, and I'm getting the following messages in the *CLI
*when I run asterisk manually:

[Apr  6 16:05:35] WARNING[14976]: app_rpt.c:22240 rpt_master: rpt_thread
restarted on node 28615
[Apr  6 16:05:35] WARNING[15001]: chan_dahdi.c:928 dahdi_open: Unable to
open '/dev/dahdi/pseudo': No such file or directory
[Apr  6 16:05:35] ERROR[15001]: chan_dahdi.c:7906 chandup: Unable to dup
channel: No such file or directory

Seems to be dahdi is missing.  Any ideas how to remedy?

I have tried to* recompile Dahdi *from:

http://wiki.allstarlink.org/wiki/DAHDI_Make

After running the "*make*" command I get the following:

"*You do not appear to have the sources for the 2.6.32-042stab127.2 kernel
installed.*"

I can't seem to find how to update/install *2.6.32-042stab127.2 kernel*.


Monty
KE7JVX
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20180406/29342503/attachment.html>


More information about the App_rpt-users mailing list