[App_rpt-users] Problems with setup from newest image

Jeremy Utley jerutley at gmail.com
Wed Apr 11 17:43:05 EDT 2018


So last week while I was on vacation, I had an SD card filesystem go corrupt
- lots of damaged files, Asterisk segfaulting on startup, all kinds of weird
stuff happening.  So I decided to rebuild this node (45984) with the newest
stuff - this was my last Arch-based node, and I wanted to get back to the
Debian base.  So, I pulled down the 20180228 raspbian stretch image, wrote
it to a new SD card, booted up the Pi, ssh'd in, expanded the filesystem,
updated all packages to latest, and went thru the setup process.  BTW, I
love the new menu-based system - but the menu should include a way to get
out to shell (if it does already, I apologize, but I did not see an option
for that in it).

 

After I did the node setup, and the pi rebooted, I'm getting odd errors from
trying to start Asterisk.  Here's an entry from journalctl:

 

Apr 11 16:14:33 uhf.wi0la.org systemd[1]: asterisk.service: Job
asterisk.service/start failed with result 'dependency'.

Apr 11 16:14:33 uhf.wi0la.org systemd[1]: dev-dahdi-pseudo.device: Job
dev-dahdi-pseudo.device/start failed with result 'timeout'.

 

I'm suspecting that the upgrade of the kernel I did on the first boot is
making Dahdi not come up properly, so I'm trying a rebuild of Dahdi via:

 

apt-get install --reinstall asl-dahdi-linux-dkms

 

Don't know if this will fix the problem or not - will know as soon as the
process finishes.  But isn't DKMS supposed to handle this automatically?

 

Jeremy, NQ0M

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20180411/780fc896/attachment.html>


More information about the App_rpt-users mailing list