[App_rpt-users] 3. Limey Linux Questions / Help (Marshall Oldham)

George Csahanin george at dyb.com
Thu Dec 20 16:52:10 EST 2018


>     3. Limey Linux Questions / Help (Marshall Oldham)
>
> _______________________________________________
> App_rpt-users mailing list
> App_rpt-users at lists.allstarlink.org
> http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users


Marshall, just yesterday I updated my Limey to the latest 
allstar/asterisk. I first tried just replacing the app_rpt.c file but 
that didn't fly. So I got the whole thing from github and in Limey I did 
getsrc then in the source tree went into the asterisk directory and 
deleted all. Next dropped the new asterisk/allstar source in to the 
directory. Some make files have permissions set to where it would not 
compile but I simply did 'chmod 755 * -R' and then went back up to the 
/usr/src/astsrc directrory and did 'make genconfig' First menu came up 
no changes needed, escape out and then more time till the main menu for 
asterisk comes up. Select as needed, escape out, hit "S" for save and 
let it compile.

I got errors when the system was out of memory. So I tried again but 
eliminated echolink, channel voter and stuff I knew I didn't need. And 
especially the sound files, didn't compile them. They were already on 
the computer. Then it compiled and applied the new asterisk executable. 
But then you need to save it and for some reason the script "svastbin" 
didn't place the newly compiled asterisk on the cf card, so I moved it 
manually from /root and reboot, all went fine, it works great. My reason 
was to allow allmon to work with this node. The old 0.287 source didn't 
know about allmon.

Hope this helps.

Just curious, how long has your cf card been in service? Mine's been 
running since 2012.

GeorgeC W2DB 2360

-- 
George Csahanin
10100 Carson Ranch Rd.
Crowley, TX 76036
682-708-5716 home
401-338-0568 cel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.allstarlink.org/pipermail/app_rpt-users/attachments/20181220/b33908df/attachment.html>


More information about the App_rpt-users mailing list