[App_rpt-users] Registration vs online question

Michael Wolthuis wolthuis at gmail.com
Wed Jan 10 10:37:07 EST 2018


Thanks David,
Ping = DNS resolves and pings fine
The wget test command returns exactly the output you listed.

Other recommendations to test?
Mike
Kb8zgl


On 1/10/18, 10:30 AM, "App_rpt-users on behalf of David McGough" <app_rpt-users-bounces at lists.allstarlink.org on behalf of kb4fxc at inttek.net> wrote:

    
    Hi Mike,
    
    For some reason your wget queries are never reaching the stats server. 
    This could be a DNS issue--are your able to ping stats.allstarlink.org ??
    
    If you can ping the stats server, wget isn't working properly, for some 
    reason.
    
    As a test, this wget command (run from the shell prompt) should return 
    a short segment of html code:
    
    wget -O- -q 'http://stats.allstarlink.org/nodeinfo.cgi?node=2000'
    
    
    ...The output should look roughly like:
    
    <h1><center>Node 2000</center></h1>
    
    <BR><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN">
    <HTML>
    <link rel="stylesheet" type="text/css" href="style.css" />
    <HEAD>
    <TITLE>Statistics by Node</TITLE>
    </HEAD>
    <BODY>
    <h2><center>Statistics</center></h2>
    <br>
    <table>
    <tr><th ALIGN=LEFT>Actual Uptime</th><td>4D 10H 56M 28S</td></tr>
    <tr><th ALIGN=LEFT>Total Keyups</th><td>126</td></tr>
    <tr><th ALIGN=LEFT>Total Transmit Time</th><td>29M 1S</td></tr>
    <tr><th ALIGN=LEFT>Total Time Outs</th><td>0</td></tr
    ><tr><th ALIGN=LEFT>Total Commands Executed</th><td>0</td></tr>
    </table>
    </BODY>
    </HTML>
    
    
    (The html format needs to be cleaned up a little, but it works)
    
    73, David KB4FXC
    
    On Wed, 10 Jan 2018, Michael Wolthuis wrote:
    
    > I am having this same problem for node #28241.  I have confirmed wget is present and that both of the statpost lines are in rpt.conf.
    > If I look at it at stats.allstarlink.org it says Can not find info for node 28241
    > 
    > Anyone have any further ways to test where this is broken?  This is an older pickle install on a Beagle-XM, next step is to replace with Steve's latest DIAL release.
    > 
    > Mike
    > Kb8zgl
    > 
    > 
    > On 1/9/18, 6:56 PM, "App_rpt-users on behalf of Bryan D. Boyle" <app_rpt-users-bounces at lists.allstarlink.org on behalf of bdboyle at bdboyle.com> wrote:
    > 
    >     Duh.  I feel dumb.  You'd think after 9 years of running Allstar 
    >     nodes...I'd not miss something like this.
    >     
    >     Thanks, David.
    >     
    >     (now, have to figure out why it's auto congesting between a hardware 
    >     node and a hub node on the same Pi...both can connect out from same 
    >     hardware, but not to each other.  Not that it's a big deal, but...)
    >     
    >     BB
    >     WB0YLE/W2FUV
    >     
    >     On 1/9/2018 6:43 PM, David McGough wrote:
    >     > Hi Bryan,
    >     >
    >     > Your AllStar nodes don't appear to be reporting and data to the stats
    >     > server. Make sure that all your node stanzas in the /etc/asterisk/rpt.conf
    >     > file include these statements:
    >     >
    >     > statpost_program=/usr/bin/wget,-q,--timeout=15,--tries=1,--output-document=/dev/null
    >     > statpost_url=http://stats.allstarlink.org/uhandler.php
    >     >
    >     > ...If you've already got these statements, make sure that the
    >     > /usr/bin/wget program is present and working.
    >     >
    >     >
    >     > 73, David KB4FXC
    >     >
    >     >
    >     
    >     _______________________________________________
    >     App_rpt-users mailing list
    >     App_rpt-users at lists.allstarlink.org
    >     http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
    >     
    >     To unsubscribe from this list please visit http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button"
    >     You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem. 
    > _______________________________________________
    App_rpt-users mailing list
    App_rpt-users at lists.allstarlink.org
    http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
    
    To unsubscribe from this list please visit http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button"
    You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem. 
    
    _______________________________________________
    App_rpt-users mailing list
    App_rpt-users at lists.allstarlink.org
    http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users
    
    To unsubscribe from this list please visit http://lists.allstarlink.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button"
    You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem. 


More information about the App_rpt-users mailing list